Не запускается gslapt

Russian forum

Moderator: posixru

research
Posts: 11
Joined: 5. Jun 2016, 17:49

Re: Не запускается gslapt

Post by research » 17. Oct 2018, 06:51

Получилась такая портянка
user[~]$ sudo upgradepkg --install -new libgpg-error-1.23-x86_64-1.txz
Password:
Cannot install --install: file not found
Cannot install -new: file not found
Cannot install libgpg-error-1.23-x86_64-1.txz: file not found

user[~]$ sudo upgradepkg --install -new libgpg-error-1.23-x86_64-1.txz
Cannot install --install: file not found
Cannot install -new: file not found
Cannot install libgpg-error-1.23-x86_64-1.txz: file not found

user[~]$ sudo upgradepkg --install -new libgpg-error-1.23-x86_64-1.txz
Cannot install --install: file not found
Cannot install -new: file not found
Cannot install libgpg-error-1.23-x86_64-1.txz: file not found

user[~]$ sudo upgradepkg --install -new libgpg-error-1.11-x86_64-1.txz
Cannot install --install: file not found
Cannot install -new: file not found

+==============================================================================
| Upgrading libgpg-error-1.11-i486-1 package using ./libgpg-error-1.11-x86_64-1.txz
+==============================================================================

Pre-installing package libgpg-error-1.11-x86_64-1...

Removing package /var/log/packages/libgpg-error-1.11-i486-1-upgraded-2018-10-17,10:32:21...
--> Deleting symlink /lib/libgpg-error.so.0
--> Deleting symlink /usr/lib/libgpg-error.so
--> Deleting symlink /usr/lib/libgpg-error.so.0
--> Deleting symlink /usr/lib/libgpg-error.so.0.9.0
--> Deleting /lib/libgpg-error.so.0.9.0
--> Deleting /usr/lib/libgpg-error.a
--> Deleting /usr/lib/libgpg-error.la

Verifying package libgpg-error-1.11-x86_64-1.txz.
Installing package libgpg-error-1.11-x86_64-1.txz:
PACKAGE DESCRIPTION:
# libgpg-error (GnuPG Error Definitions Library)
#
# This is a library that defines common error values for all GnuPG
# components. Among these are GPG, GPGSM, GPGME, GPG-Agent,
# libgcrypt, Libksba, DirMngr, Pinentry, SmartCard Daemon, and more.
#
Executing install script for libgpg-error-1.11-x86_64-1.txz.
Package libgpg-error-1.11-x86_64-1.txz installed.

Package libgpg-error-1.11-i486-1 upgraded with new package ./libgpg-error-1.11-x86_64-1.txz.

user[~]$ sudo upgradepkg --install -new gpgme-1.4.1-x86_64-1.txz
Cannot install --install: file not found
Cannot install -new: file not found

+==============================================================================
| Upgrading gpgme-1.9.0-i586-1 package using ./gpgme-1.4.1-x86_64-1.txz
+==============================================================================

Pre-installing package gpgme-1.4.1-x86_64-1...

Removing package /var/log/packages/gpgme-1.9.0-i586-1-upgraded-2018-10-17,10:35:21...
--> Deleting symlink /usr/lib/libgpgme.so
--> Deleting symlink /usr/lib/libgpgme.so.11
--> Deleting symlink /usr/lib/libgpgmepp.so
--> Deleting symlink /usr/lib/libgpgmepp.so.6
--> Deleting /usr/bin/gpgme-tool
--> Deleting /usr/doc/gpgme-1.9.0/AUTHORS
--> Deleting /usr/doc/gpgme-1.9.0/COPYING
--> Deleting /usr/doc/gpgme-1.9.0/COPYING.LESSER
--> Deleting /usr/doc/gpgme-1.9.0/ChangeLog
--> Deleting /usr/doc/gpgme-1.9.0/INSTALL
--> Deleting /usr/doc/gpgme-1.9.0/NEWS
--> Deleting /usr/doc/gpgme-1.9.0/README
--> Deleting /usr/doc/gpgme-1.9.0/THANKS
--> Deleting /usr/doc/gpgme-1.9.0/TODO
--> Deleting /usr/doc/gpgme-1.9.0/VERSION
--> Deleting /usr/include/gpgme++/configuration.h
--> Deleting /usr/include/gpgme++/context.h
--> Deleting /usr/include/gpgme++/data.h
--> Deleting /usr/include/gpgme++/decryptionresult.h
--> Deleting /usr/include/gpgme++/defaultassuantransaction.h
--> Deleting /usr/include/gpgme++/editinteractor.h
--> Deleting /usr/include/gpgme++/encryptionresult.h
--> Deleting /usr/include/gpgme++/engineinfo.h
--> Deleting /usr/include/gpgme++/error.h
--> Deleting /usr/include/gpgme++/eventloopinteractor.h
--> Deleting /usr/include/gpgme++/exception.h
--> Deleting /usr/include/gpgme++/global.h
--> Deleting /usr/include/gpgme++/gpgadduserideditinteractor.h
--> Deleting /usr/include/gpgme++/gpgagentgetinfoassuantransaction.h
--> Deleting /usr/include/gpgme++/gpggencardkeyinteractor.h
--> Deleting /usr/include/gpgme++/gpgmefw.h
--> Deleting /usr/include/gpgme++/gpgmepp_export.h
--> Deleting /usr/include/gpgme++/gpgmepp_version.h
--> Deleting /usr/include/gpgme++/gpgsetexpirytimeeditinteractor.h
--> Deleting /usr/include/gpgme++/gpgsetownertrusteditinteractor.h
--> Deleting /usr/include/gpgme++/gpgsignkeyeditinteractor.h
--> Deleting /usr/include/gpgme++/importresult.h
--> Deleting /usr/include/gpgme++/interfaces/assuantransaction.h
--> Deleting /usr/include/gpgme++/interfaces/dataprovider.h
--> Deleting /usr/include/gpgme++/interfaces/passphraseprovider.h
--> Deleting /usr/include/gpgme++/interfaces/progressprovider.h
--> Deleting /usr/include/gpgme++/key.h
--> Deleting /usr/include/gpgme++/keygenerationresult.h
--> Deleting /usr/include/gpgme++/keylistresult.h
--> Deleting /usr/include/gpgme++/notation.h
--> Deleting /usr/include/gpgme++/result.h
--> Deleting /usr/include/gpgme++/scdgetinfoassuantransaction.h
--> Deleting /usr/include/gpgme++/signingresult.h
--> Deleting /usr/include/gpgme++/swdbresult.h
--> Deleting /usr/include/gpgme++/tofuinfo.h
--> Deleting /usr/include/gpgme++/trustitem.h
--> Deleting /usr/include/gpgme++/verificationresult.h
--> Deleting /usr/include/gpgme++/vfsmountresult.h
--> Deleting /usr/lib/cmake/Gpgmepp/GpgmeppConfig.cmake
--> Deleting /usr/lib/cmake/Gpgmepp/GpgmeppConfigVersion.cmake
--> Deleting /usr/lib/libgpgme.la
--> Deleting /usr/lib/libgpgme.so.11.18.0
--> Deleting /usr/lib/libgpgmepp.la
--> Deleting /usr/lib/libgpgmepp.so.6.4.0
--> Deleting /usr/lib/python2.7/site-packages/gpg-1.9.0-py2.7.egg-info
--> Deleting /usr/lib/python2.7/site-packages/gpg/__init__.py
--> Deleting /usr/lib/python2.7/site-packages/gpg/__init__.pyc
--> Deleting /usr/lib/python2.7/site-packages/gpg/_gpgme.so
--> Deleting /usr/lib/python2.7/site-packages/gpg/callbacks.py
--> Deleting /usr/lib/python2.7/site-packages/gpg/callbacks.pyc
--> Deleting /usr/lib/python2.7/site-packages/gpg/constants/__init__.py
--> Deleting /usr/lib/python2.7/site-packages/gpg/constants/__init__.pyc
--> Deleting /usr/lib/python2.7/site-packages/gpg/constants/create.py
--> Deleting /usr/lib/python2.7/site-packages/gpg/constants/create.pyc
--> Deleting /usr/lib/python2.7/site-packages/gpg/constants/data/__init__.py
--> Deleting /usr/lib/python2.7/site-packages/gpg/constants/data/__init__.pyc
--> Deleting /usr/lib/python2.7/site-packages/gpg/constants/data/encoding.py
--> Deleting /usr/lib/python2.7/site-packages/gpg/constants/data/encoding.pyc
--> Deleting /usr/lib/python2.7/site-packages/gpg/constants/event.py
--> Deleting /usr/lib/python2.7/site-packages/gpg/constants/event.pyc
--> Deleting /usr/lib/python2.7/site-packages/gpg/constants/import.py
--> Deleting /usr/lib/python2.7/site-packages/gpg/constants/import.pyc
--> Deleting /usr/lib/python2.7/site-packages/gpg/constants/keylist/__init__.py
--> Deleting /usr/lib/python2.7/site-packages/gpg/constants/keylist/__init__.pyc
--> Deleting /usr/lib/python2.7/site-packages/gpg/constants/keylist/mode.py
--> Deleting /usr/lib/python2.7/site-packages/gpg/constants/keylist/mode.pyc
--> Deleting /usr/lib/python2.7/site-packages/gpg/constants/keysign.py
--> Deleting /usr/lib/python2.7/site-packages/gpg/constants/keysign.pyc
--> Deleting /usr/lib/python2.7/site-packages/gpg/constants/md.py
--> Deleting /usr/lib/python2.7/site-packages/gpg/constants/md.pyc
--> Deleting /usr/lib/python2.7/site-packages/gpg/constants/pk.py
--> Deleting /usr/lib/python2.7/site-packages/gpg/constants/pk.pyc
--> Deleting /usr/lib/python2.7/site-packages/gpg/constants/protocol.py
--> Deleting /usr/lib/python2.7/site-packages/gpg/constants/protocol.pyc
--> Deleting /usr/lib/python2.7/site-packages/gpg/constants/sig/__init__.py
--> Deleting /usr/lib/python2.7/site-packages/gpg/constants/sig/__init__.pyc
--> Deleting /usr/lib/python2.7/site-packages/gpg/constants/sig/mode.py
--> Deleting /usr/lib/python2.7/site-packages/gpg/constants/sig/mode.pyc
--> Deleting /usr/lib/python2.7/site-packages/gpg/constants/sig/notation.py
--> Deleting /usr/lib/python2.7/site-packages/gpg/constants/sig/notation.pyc
--> Deleting /usr/lib/python2.7/site-packages/gpg/constants/sigsum.py
--> Deleting /usr/lib/python2.7/site-packages/gpg/constants/sigsum.pyc
--> Deleting /usr/lib/python2.7/site-packages/gpg/constants/status.py
--> Deleting /usr/lib/python2.7/site-packages/gpg/constants/status.pyc
--> Deleting /usr/lib/python2.7/site-packages/gpg/constants/tofu/__init__.py
--> Deleting /usr/lib/python2.7/site-packages/gpg/constants/tofu/__init__.pyc
--> Deleting /usr/lib/python2.7/site-packages/gpg/constants/tofu/policy.py
--> Deleting /usr/lib/python2.7/site-packages/gpg/constants/tofu/policy.pyc
--> Deleting /usr/lib/python2.7/site-packages/gpg/constants/validity.py
--> Deleting /usr/lib/python2.7/site-packages/gpg/constants/validity.pyc
--> Deleting /usr/lib/python2.7/site-packages/gpg/core.py
--> Deleting /usr/lib/python2.7/site-packages/gpg/core.pyc
--> Deleting /usr/lib/python2.7/site-packages/gpg/errors.py
--> Deleting /usr/lib/python2.7/site-packages/gpg/errors.pyc
--> Deleting /usr/lib/python2.7/site-packages/gpg/gpgme.py
--> Deleting /usr/lib/python2.7/site-packages/gpg/gpgme.pyc
--> Deleting /usr/lib/python2.7/site-packages/gpg/install_files.txt
--> Deleting /usr/lib/python2.7/site-packages/gpg/results.py
--> Deleting /usr/lib/python2.7/site-packages/gpg/results.pyc
--> Deleting /usr/lib/python2.7/site-packages/gpg/util.py
--> Deleting /usr/lib/python2.7/site-packages/gpg/util.pyc
--> Deleting /usr/lib/python2.7/site-packages/gpg/version.py
--> Deleting /usr/lib/python2.7/site-packages/gpg/version.pyc
--> Deleting empty directory /usr/lib/python2.7/site-packages/gpg/constants/tofu/
--> Deleting empty directory /usr/lib/python2.7/site-packages/gpg/constants/sig/
--> Deleting empty directory /usr/lib/python2.7/site-packages/gpg/constants/keylist/
--> Deleting empty directory /usr/lib/python2.7/site-packages/gpg/constants/data/
--> Deleting empty directory /usr/lib/python2.7/site-packages/gpg/constants/
--> Deleting empty directory /usr/lib/python2.7/site-packages/gpg/
--> Deleting empty directory /usr/lib/cmake/Gpgmepp/
--> Deleting empty directory /usr/include/gpgme++/interfaces/
--> Deleting empty directory /usr/include/gpgme++/
--> Deleting empty directory /usr/doc/gpgme-1.9.0/

Verifying package gpgme-1.4.1-x86_64-1.txz.
Installing package gpgme-1.4.1-x86_64-1.txz:
PACKAGE DESCRIPTION:
# gpgme (GnuPG Made Easy)
#
# GPGME (GnuPG Made Easy) is a C language library that allows to add
# support for cryptography to a program. It is designed to make access
# to public key crypto engines like GnuPG or GpgSM easier for
# applications. GPGME provides a high-level crypto API for encryption,
# decryption, signing, signature verification and key management.
#
# GPGME uses GnuPG and GpgSM as its backends to support OpenPGP and the
# Cryptographic Message Syntax (CMS).
#
Executing install script for gpgme-1.4.1-x86_64-1.txz.
Package gpgme-1.4.1-x86_64-1.txz installed.

Package gpgme-1.9.0-i586-1 upgraded with new package ./gpgme-1.4.1-x86_64-1.txz.

user[~]$ sudo upgradepkg --install -new gslapt-0.5.4c-x86_64-1.txz
Cannot install --install: file not found
Cannot install -new: file not found
Cannot install gslapt-0.5.4c-x86_64-1.txz: file not found

user[~]$ sudo upgradepkg --install -new gslapt-0.5.4c-x86_64-1gv.txz
Cannot install --install: file not found
Cannot install -new: file not found

+==============================================================================
| Upgrading gslapt-0.5.3j-i486-1gv package using ./gslapt-0.5.4c-x86_64-1gv.txz
+==============================================================================

Pre-installing package gslapt-0.5.4c-x86_64-1gv...

Removing package /var/log/packages/gslapt-0.5.3j-i486-1gv-upgraded-2018-10-17,10:38:18...
--> Deleting /usr/doc/gslapt-0.5.3j/AUTHORS
--> Deleting /usr/doc/gslapt-0.5.3j/COPYING
--> Deleting /usr/doc/gslapt-0.5.3j/ChangeLog
--> Deleting /usr/doc/gslapt-0.5.3j/FAQ
--> Deleting /usr/doc/gslapt-0.5.3j/README
--> Deleting /usr/share/gslapt/pixmaps/gslapt.png
--> Deleting /usr/share/gslapt/pixmaps/pkg_action_available.png
--> Deleting /usr/share/gslapt/pixmaps/pkg_action_available_excluded.png
--> Deleting /usr/share/gslapt/pixmaps/pkg_action_downgrade.png
--> Deleting /usr/share/gslapt/pixmaps/pkg_action_install.png
--> Deleting /usr/share/gslapt/pixmaps/pkg_action_installed.png
--> Deleting /usr/share/gslapt/pixmaps/pkg_action_installed_excluded.png
--> Deleting /usr/share/gslapt/pixmaps/pkg_action_reinstall.png
--> Deleting /usr/share/gslapt/pixmaps/pkg_action_remove.png
--> Deleting /usr/share/gslapt/pixmaps/pkg_action_upgrade.png
--> Deleting /usr/src/gslapt-0.5.3j/SLKBUILD
--> Deleting /usr/src/gslapt-0.5.3j/newpixmaps.tar.gz
--> Deleting empty directory /usr/src/gslapt-0.5.3j/
--> Deleting empty directory /usr/share/gslapt/pixmaps/
--> Deleting empty directory /usr/doc/gslapt-0.5.3j/

Verifying package gslapt-0.5.4c-x86_64-1gv.txz.
Installing package gslapt-0.5.4c-x86_64-1gv.txz:
PACKAGE DESCRIPTION:
# gslapt (a GTK version of slapt-get)
#
# gslapt is a graphical package manager for slackware and slackware
# based distributions that uses the slapt-get command line interface
# package management tool.
#
# Homepage: http://software.jaos.org/
#
# Please translate:
# http://software.jaos.org/git/gslapt/tree/po
#
Package gslapt-0.5.4c-x86_64-1gv.txz installed.

Package gslapt-0.5.3j-i486-1gv upgraded with new package ./gslapt-0.5.4c-x86_64-1gv.txz.

user[~]$ sudo upgradepkg --install -new slapt-get-0.10.2t-x86_64-1gv.txz
Cannot install --install: file not found
Cannot install -new: file not found

+==============================================================================
| Upgrading slapt-get-0.10.2q-i486-2gv package using ./slapt-get-0.10.2t-x86_64-1gv.txz
+==============================================================================

Pre-installing package slapt-get-0.10.2t-x86_64-1gv...

Removing package /var/log/packages/slapt-get-0.10.2q-i486-2gv-upgraded-2018-10-17,10:39:40...
--> Deleting symlink /usr/lib/libslapt.so
--> Deleting /usr/doc/slapt-get-0.10.2q/COPYING
--> Deleting /usr/doc/slapt-get-0.10.2q/ChangeLog
--> Deleting /usr/doc/slapt-get-0.10.2q/FAQ
--> Deleting /usr/doc/slapt-get-0.10.2q/FAQ.html
--> Deleting /usr/doc/slapt-get-0.10.2q/INSTALL
--> Deleting /usr/doc/slapt-get-0.10.2q/README
--> Deleting /usr/doc/slapt-get-0.10.2q/TODO
--> Deleting /usr/doc/slapt-get-0.10.2q/default.slapt-getrc.arm
--> Deleting /usr/doc/slapt-get-0.10.2q/default.slapt-getrc.i486
--> Deleting /usr/doc/slapt-get-0.10.2q/default.slapt-getrc.x86_64
--> Deleting /usr/doc/slapt-get-0.10.2q/example.slapt-getrc.i386
--> Deleting /usr/doc/slapt-get-0.10.2q/example.slapt-getrc.x86_64
--> Deleting /usr/lib/libslapt.so.0.10.2q
--> Deleting /usr/src/slapt-get-0.10.2q/0001-fix-conflict-reverse-dep-resolution-when-installing-.patch
--> Deleting /usr/src/slapt-get-0.10.2q/SLKBUILD
--> Deleting /usr/src/slapt-get-0.10.2q/libslapt-deps.patch
--> Deleting /usr/src/slapt-get-0.10.2q/slapt-get-0.10.2g-spkg.patch
--> Deleting /usr/src/slapt-get-0.10.2q/slapt-getrc.i486
--> Deleting /usr/src/slapt-get-0.10.2q/slapt-getrc.x86_64
--> Deleting empty directory /usr/src/slapt-get-0.10.2q/
--> Deleting empty directory /usr/doc/slapt-get-0.10.2q/

Verifying package slapt-get-0.10.2t-x86_64-1gv.txz.
Installing package slapt-get-0.10.2t-x86_64-1gv.txz:
PACKAGE DESCRIPTION:
# slapt-get (an apt like system for Slackware package management)
#
# slapt-get allows one to search slackware and compatible repositories
# for packages, compare them with installed packages, install new
# packages or upgrade installed packages all with a few simple commands.
# * See /usr/doc/slapt-get-0.10.2t/ for complete documentation.
# * Support:
# http://software.jaos.org/cgi-bin/mailma ... t-get-user
# * Please translate:
# http://software.jaos.org/git/slapt-get/tree/po
# then send to slapt-get-devel@software.jaos.org
Executing install script for slapt-get-0.10.2t-x86_64-1gv.txz.
Package slapt-get-0.10.2t-x86_64-1gv.txz installed.

Package slapt-get-0.10.2q-i486-2gv upgraded with new package ./slapt-get-0.10.2t-x86_64-1gv.txz.

user[~]$ sudo slapt-get
/usr/sbin/slapt-get: /usr/sbin/slapt-get: cannot execute binary file
user[~]$ sudo gslapt
/usr/sbin/gslapt: /usr/sbin/gslapt: cannot execute binary file
user[~]$ sudo slapt-get --add-keys
/usr/sbin/slapt-get: /usr/sbin/slapt-get: cannot execute binary file
user[~]$ sudo slapt-get -i glapt gpgme libgpg-error
/usr/sbin/slapt-get: /usr/sbin/slapt-get: cannot execute binary file
user[~]$ sudo slapt-get -i gslapt gpgme libgpg-error
/usr/sbin/slapt-get: /usr/sbin/slapt-get: cannot execute binary file
user[~]$ sudo slapt-get -i --reinstall gslapt gpgme libgpg-error
/usr/sbin/slapt-get: /usr/sbin/slapt-get: cannot execute binary file
user[~]$ slapt-get --help
bash: /usr/sbin/slapt-get: cannot execute binary file
user[~]$ sudo spi -u
Updating package cache...
Traceback (most recent call last):
File "/usr/libexec/spi.py", line 500, in <module>
main(sys.argv[1:])
File "/usr/libexec/spi.py", line 70, in main
retval = update()
File "/usr/libexec/spi.py", line 309, in update
p = subprocess.Popen([slaptget, '--update'])
File "/usr/lib/python2.7/subprocess.py", line 711, in __init__
errread, errwrite)
File "/usr/lib/python2.7/subprocess.py", line 1308, in _execute_child
raise child_exception
OSError: [Errno 8] Exec format error
user[~]$ sudo spi -U
Traceback (most recent call last):
File "/usr/libexec/spi.py", line 500, in <module>
main(sys.argv[1:])
File "/usr/libexec/spi.py", line 73, in main
retval = upgrade()
File "/usr/libexec/spi.py", line 321, in upgrade
p = subprocess.Popen([slaptget, '--upgrade'])
File "/usr/lib/python2.7/subprocess.py", line 711, in __init__
errread, errwrite)
File "/usr/lib/python2.7/subprocess.py", line 1308, in _execute_child
raise child_exception
OSError: [Errno 8] Exec format error
user[~]$ sudo spi -i gslapt
Traceback (most recent call last):
File "/usr/libexec/spi.py", line 500, in <module>
main(sys.argv[1:])
File "/usr/libexec/spi.py", line 95, in main
install(args)
File "/usr/libexec/spi.py", line 258, in install
pl = pkglist(args)
File "/usr/libexec/spi.py", line 136, in pkglist
stderr=subprocess.PIPE, env=env)
File "/usr/lib/python2.7/subprocess.py", line 711, in __init__
errread, errwrite)
File "/usr/lib/python2.7/subprocess.py", line 1308, in _execute_child
raise child_exception
OSError: [Errno 8] Exec format error
user[~]$

User avatar
posixru
Posts: 432
Joined: 27. Mar 2010, 14:54
Location: СССР
Contact:

Re: Не запускается gslapt

Post by posixru » 17. Oct 2018, 16:09

research wrote:
17. Oct 2018, 06:51
Получилась такая портянка
Повторяю, скачайте пакеты libgpg-error, gpgme, slapt-get и gslapt, а потом в каталоге с пакетами выполните:

Code: Select all

sudo installpkg *.txz
Это принудительно переустановит пакеты а не обновит...
Image

User avatar
pondogor
Posts: 39
Joined: 6. Jun 2012, 10:43
Contact:

Re: Не запускается gslapt

Post by pondogor » 31. Oct 2018, 11:27

Можно попробовать:

Code: Select all

sudo su

Code: Select all

gslapt
Если запустится то это в libgksu проблема, переустановить его. Было у меня похожее, я тогда от Slackel реп подцепил и неглядя обновил KDE и всё остальное.
Image

research
Posts: 11
Joined: 5. Jun 2016, 17:49

Re: Не запускается gslapt

Post by research » 4. Nov 2018, 19:50

user[~]$ sudo su
root[user]# gslapt
bash: /usr/sbin/gslapt: cannot execute binary file
root[user]# slapt-get
bash: /usr/sbin/slapt-get: cannot execute binary file
root[user]#
Предыдущая инструкция к этому моменту выполнена

research
Posts: 11
Joined: 5. Jun 2016, 17:49

Re: Не запускается gslapt

Post by research » 4. Nov 2018, 19:55

posixru wrote:
17. Oct 2018, 16:09
research wrote:
17. Oct 2018, 06:51
Получилась такая портянка
Повторяю, скачайте пакеты libgpg-error, gpgme, slapt-get и gslapt, а потом в каталоге с пакетами выполните:

Code: Select all

sudo installpkg *.txz
Это принудительно переустановит пакеты а не обновит...
user[~]$ sudo installpkg *.txz
Password:
Verifying package gpgme-1.4.1-x86_64-1.txz.
Installing package gpgme-1.4.1-x86_64-1.txz:
PACKAGE DESCRIPTION:
# gpgme (GnuPG Made Easy)
#
# GPGME (GnuPG Made Easy) is a C language library that allows to add
# support for cryptography to a program. It is designed to make access
# to public key crypto engines like GnuPG or GpgSM easier for
# applications. GPGME provides a high-level crypto API for encryption,
# decryption, signing, signature verification and key management.
#
# GPGME uses GnuPG and GpgSM as its backends to support OpenPGP and the
# Cryptographic Message Syntax (CMS).
#
Executing install script for gpgme-1.4.1-x86_64-1.txz.
Package gpgme-1.4.1-x86_64-1.txz installed.

Verifying package gslapt-0.5.4c-x86_64-1gv.txz.
Installing package gslapt-0.5.4c-x86_64-1gv.txz:
PACKAGE DESCRIPTION:
# gslapt (a GTK version of slapt-get)
#
# gslapt is a graphical package manager for slackware and slackware
# based distributions that uses the slapt-get command line interface
# package management tool.
#
# Homepage: http://software.jaos.org/
#
# Please translate:
# http://software.jaos.org/git/gslapt/tree/po
#
Package gslapt-0.5.4c-x86_64-1gv.txz installed.

Verifying package libgpg-error-1.11-x86_64-1.txz.
Installing package libgpg-error-1.11-x86_64-1.txz:
PACKAGE DESCRIPTION:
# libgpg-error (GnuPG Error Definitions Library)
#
# This is a library that defines common error values for all GnuPG
# components. Among these are GPG, GPGSM, GPGME, GPG-Agent,
# libgcrypt, Libksba, DirMngr, Pinentry, SmartCard Daemon, and more.
#
Executing install script for libgpg-error-1.11-x86_64-1.txz.
Package libgpg-error-1.11-x86_64-1.txz installed.

Verifying package slapt-get-0.10.2t-x86_64-1gv.txz.
Installing package slapt-get-0.10.2t-x86_64-1gv.txz:
PACKAGE DESCRIPTION:
# slapt-get (an apt like system for Slackware package management)
#
# slapt-get allows one to search slackware and compatible repositories
# for packages, compare them with installed packages, install new
# packages or upgrade installed packages all with a few simple commands.
# * See /usr/doc/slapt-get-0.10.2t/ for complete documentation.
# * Support:
# http://software.jaos.org/cgi-bin/mailma ... t-get-user
# * Please translate:
# http://software.jaos.org/git/slapt-get/tree/po
# then send to slapt-get-devel@software.jaos.org
Executing install script for slapt-get-0.10.2t-x86_64-1gv.txz.
Package slapt-get-0.10.2t-x86_64-1gv.txz installed.
А дальше было так
user[~]$ gslapt
bash: /usr/sbin/gslapt: cannot execute binary file
Увы

User avatar
pondogor
Posts: 39
Joined: 6. Jun 2012, 10:43
Contact:

Re: Не запускается gslapt

Post by pondogor » 7. Nov 2018, 08:47

research wrote:
4. Nov 2018, 19:50
user[~]$ sudo su
root[user]# gslapt
bash: /usr/sbin/gslapt: cannot execute binary file
Попробуйте выполнить:

Code: Select all

sudo chmod +x /usr/sbin/gslapt
Это делает файл исполняемым. Вы кстати ставили 32 Бит или 64 Бит систему?
Как то в теме я этого не увидел, покажите что выдаёт команда:

Code: Select all

uname -a
Похожее бывает когда я по ошибке на 32 ставят 64 битный пакет, или репы не те подцеплены были.
Что у вас написано в файле:

Code: Select all

/etc/slapt-get/slapt-getrc
Вспомнилась эта тема с linuxquestions.org
Image

Post Reply