Xfce4-xkb-plugin (переключатель раскладки) [OK]

Russian forum

Moderator: posixru

User avatar
Andyun
Posts: 456
Joined: 17. Jun 2010, 09:51
Location: Russia: Severodvinsk / Россия: Северодвинск

Xfce4-xkb-plugin (переключатель раскладки) [OK]

Post by Andyun » 28. Dec 2011, 16:49

Здравствуйте!
У меня, в Salix 13.1.2 Xfce i486, постоянно вылетает Xfce-плагин переключения раскладки клавиатуры, после того, как в трее появляются значки запущенных приложений, например Скайпа. Кто-нибудь знает, как это исправить? Может, возможно установить альтернативный переключатель?
Благодарю вас!
Last edited by Andyun on 9. Jun 2012, 16:33, edited 1 time in total.

User avatar
posixru
Posts: 440
Joined: 27. Mar 2010, 14:54
Location: СССР
Contact:

Re: Xfce4-xkb-plugin (переключатель раскладки)

Post by posixru » 29. Dec 2011, 00:28

Кто-нибудь знает, как это исправить?
Как то было, немного похожее, исправилось после смены "Модели клавиатуры" (автоматом видать неправильно определилась). Больше как то ничего и не вспоминается...
Загрузил XFCE, позапускал в трей, всё вроде бы работает:

Image
Может, возможно установить альтернативный переключатель?
Есть переключатели в трее: Xneur, xxkb (те что вспомнил) и sbxkb (только что проверил на работоспособность):

Image
ЗЫ: У меня Salix XFCE, но с Openbox и панелью lxpanel, я добавил в автозапуск (~/.config/openbox/autostart.sh):

Code: Select all

setxkbmap -layout de,ru -variant -option grp:lwin_toggle,grp_led:scroll,terminate:ctrl_alt_bksp &
И стандартным флажком lxpanel переключения прекрасно инициируется раскладка...

Image
Image

User avatar
Andyun
Posts: 456
Joined: 17. Jun 2010, 09:51
Location: Russia: Severodvinsk / Россия: Северодвинск

Re: Xfce4-xkb-plugin (переключатель раскладки)

Post by Andyun » 29. Dec 2011, 23:31

Благодарю за подробный и наглядный комментарий! Действительно, после выбора клавиатуры с "Клавиатура, управляемая посредством Evdev" (по умолчанию) на "Dell 101-клавишный PC", плагин раскладки больше пока не вылетает. :)

User avatar
Andyun
Posts: 456
Joined: 17. Jun 2010, 09:51
Location: Russia: Severodvinsk / Россия: Северодвинск

Re: Xfce4-xkb-plugin (переключатель раскладки)

Post by Andyun » 18. Mar 2012, 14:27

Как оказалось позже, это тоже не помогает, плагин вылетает в Salix OS 13.1 и 13.37. Выбор модели клавиатуры не влияет на это. Лог ошибок записывается в ~.xsession-errors.

User avatar
posixru
Posts: 440
Joined: 27. Mar 2010, 14:54
Location: СССР
Contact:

Re: Xfce4-xkb-plugin (переключатель раскладки)

Post by posixru » 18. Mar 2012, 14:44

оказалось позже, это тоже не помогает, плагин вылетает в Salix OS 13.1 и 13.37. Выбор модели клавиатуры не влияет
Не знаю даже чего и подсказать... Разве что из репов Вектора попробовать поставить пакет плагина xfce4-xkb-plugin:

Code: Select all

http://vectorlinux.osuosl.org/veclinux-7.0/packages/ 

Code: Select all

http://vectorlinux.osuosl.org/veclinux-7.0/extra/ 

Code: Select all

http://vectorlinux.osuosl.org/veclinux-7.0/patches/
У меня эти репы давно используются...
Image

User avatar
Andyun
Posts: 456
Joined: 17. Jun 2010, 09:51
Location: Russia: Severodvinsk / Россия: Северодвинск

Re: Xfce4-xkb-plugin (переключатель раскладки)

Post by Andyun » 12. Apr 2012, 08:54

Для Salix OS 13.37 я нашёл такое решение:
1. Удалить файл(ы) xkb-плагина в /home/домашняя_папка_пользователя/.config/xfce4/panel/xkb-plugin-*.rc.
2. От лица root подредактировать файл /etc/X11/xorg.conf.d/10-keymap.conf. В нём должны быть такие строчки:

Code: Select all

	Option		"XkbLayout" "us,ru"
	Option		"XkbOptions" "grp:alt_shift_toggle,grp_led:scroll"
3. Перезапустить x-сервер (можно выйти и снова войти в систему). Готово! Раскладка будет переключаться комбинацией клавиш "Alt+Shift" с индикацией лампочкой на клавиатуре.

GLvova
Posts: 10
Joined: 27. Mar 2012, 08:41

Re: Xfce4-xkb-plugin (переключатель раскладки)

Post by GLvova » 24. Apr 2012, 05:00

Есть способ куда более удобный чем править xorg.conf.
Забиваете в авторан
$ setxkbmap -layout "us,ru,ua" -option "grp:rwin_toggle,grp_led:scroll" &
Языки разумеется можно поменять и тут у меня переключение происходит по кнопке "правая виндовс".

User avatar
posixru
Posts: 440
Joined: 27. Mar 2010, 14:54
Location: СССР
Contact:

Re: Xfce4-xkb-plugin (переключатель раскладки)

Post by posixru » 24. Apr 2012, 09:45

Есть способ куда более удобный чем править xorg.conf. Забиваете в авторан
Это прокатит если не нужен значок/флаг в трее или на панели... Но таких не видел, всем надо/требуется.
Засим представляю QXKB:

Image

Image

Image

Image

Image

Image

Мне понравился! Чем то он мне напоминает KDE"шный конфигуратор клавиатуры, но требует он только QT, входит в состав Qt-среды рабочего стола Razor-qt Кому надо, ТУТ (ponce.cc/slackware)есть готовый пакетик, там же кстати есть свежие пакетики Razor-qt, LXDE и ещё некоторое количество различного софта свежих версий (пакетики slackware/slackware64).
Image

GLvova
Posts: 10
Joined: 27. Mar 2012, 08:41

Re: Xfce4-xkb-plugin (переключатель раскладки)

Post by GLvova » 24. Apr 2012, 10:14

posixru wrote:
Есть способ куда более удобный чем править xorg.conf. Забиваете в авторан
Это прокатит если не нужен значок/флаг в трее или на панели... Но таких не видел, всем надо/требуется.
Если вы бы попробовали данную команду, то увидели, что при переключении на рус. раскладку - загорается лампочка Scroll Lock. Чем вам не флажок?:)
А вот за презентацию Razor-qt спасибо. И за ссылку на готовые пакетики. Еще вчера искал сие творение собранным для слаки.

User avatar
posixru
Posts: 440
Joined: 27. Mar 2010, 14:54
Location: СССР
Contact:

Re: Xfce4-xkb-plugin (переключатель раскладки)

Post by posixru » 24. Apr 2012, 11:00

Если вы бы попробовали данную команду, то увидели, что при переключении на рус. раскладку - загорается лампочка Scroll Lock. Чем вам не флажок?:)

Если бы больше года мною не пользовался Öpenbox"ик, а на моём ноуте присутствовал светодиод Scroll Lock, то я как на напольном тоже бы её наверно прямо так сразу в /etc/default/keyboard и прописал... Но... Image
А вот за презентацию Razor-qt спасибо. И за ссылку на готовые пакетики. Еще вчера искал сие творение собранным для слаки
Да не за что, пользуйте на здоровье! Image
Image

Post Reply