Problema pacchetto xautomation[RISOLTO]

Italian forum
Post Reply
User avatar
Inserviente
Posts: 76
Joined: 24. Sep 2011, 17:50
Location: Da qualche parte in Emilia Romagna(Italy)

Problema pacchetto xautomation[RISOLTO]

Post by Inserviente » 12. Apr 2012, 17:55

Ciao,ho provato ad installare da Sourcery il pacchetto xautomation,ma vi viene rilevato un errore.Il log:
********************************************
The following packages will be fetched:
xautomation
Fetching README... 0% 0%100%100%100%Done
Fetching slack-desc... 0% 0%100%100%100%Done
Fetching xautomation.SlackBuild... 0% 0% 64%100%100%100%Done
Fetching xautomation.info... 0% 0%100%100%100%Done
The following packages will be installed:
xautomation
Fetching README... 0% 0%100%100%100%Done
Fetching slack-desc... 0% 0%100%100%100%Done
Fetching xautomation.SlackBuild... 0% 0% 64%100%100%100%Done
Fetching xautomation.info... 0% 0%100%100%100%Done
xautomation-1.03/
xautomation-1.03/README
xautomation-1.03/configure.in
xautomation-1.03/aclocal.m4
xautomation-1.03/Makefile.am
xautomation-1.03/Makefile.in
xautomation-1.03/configure
xautomation-1.03/AUTHORS
xautomation-1.03/COPYING
xautomation-1.03/ChangeLog
xautomation-1.03/INSTALL
xautomation-1.03/NEWS
xautomation-1.03/depcomp
xautomation-1.03/install-sh
xautomation-1.03/missing
xautomation-1.03/mkinstalldirs
xautomation-1.03/pat2ppm.c
xautomation-1.03/image.c
xautomation-1.03/image.h
xautomation-1.03/debug.c
xautomation-1.03/debug.h
xautomation-1.03/patextract.c
xautomation-1.03/png2pat.c
xautomation-1.03/rgb2pat.c
xautomation-1.03/visgrep.c
xautomation-1.03/xmousepos.c
xautomation-1.03/xte.c
xautomation-1.03/kbd.h
xautomation-1.03/keysym_map.h
xautomation-1.03/multikey_map.h
xautomation-1.03/pat2ppm.1
xautomation-1.03/patextract.1
xautomation-1.03/png2pat.1
xautomation-1.03/rgb2pat.1
xautomation-1.03/visgrep.1
xautomation-1.03/xautomation.7
xautomation-1.03/xmousepos.1
xautomation-1.03/xte.1
checking for a BSD-compatible install... /bin/ginstall -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
checking how to run the C preprocessor... gcc -E
checking for X... libraries , headers
checking for gethostbyname... yes
checking for connect... yes
checking for remove... yes
checking for shmat... yes
checking for IceConnectionNumber in -lICE... yes
checking for png_read_info in -lpng... yes
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for stdlib.h... (cached) yes
checking for unistd.h... (cached) yes
checking wchar.h usability... yes
checking wchar.h presence... yes
checking for wchar.h... yes
checking locale.h usability... yes
checking locale.h presence... yes
checking for locale.h... yes
checking for an ANSI C-conforming const... yes
checking for stdlib.h... (cached) yes
checking for GNU libc compatible malloc... yes
checking for bzero... yes
checking for wmemset... yes
checking for mbstowcs... yes
configure: creating ./config.status
config.status: creating Makefile
config.status: executing depfiles commands
gcc -DPACKAGE_NAME=\"xautomation\" -DPACKAGE_TARNAME=\"xautomation\" -DPACKAGE_VERSION=\"1.03\" -DPACKAGE_STRING=\"xautomation\ 1.03\" -DPACKAGE_BUGREPORT=\"\" -DPACKAGE=\"xautomation\" -DVERSION=\"1.03\" -DDEBUG_A_LOO=1 -DHAVE_LIBPNG=1 -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_STDLIB_H=1 -DHAVE_UNISTD_H=1 -DHAVE_WCHAR_H=1 -DHAVE_LOCALE_H=1 -DHAVE_STDLIB_H=1 -DHAVE_MALLOC=1 -DHAVE_BZERO=1 -DHAVE_WMEMSET=1 -DHAVE_MBSTOWCS=1 -I. -O2 -march=i486 -mtune=i686 -MT xte.o -MD -MP -MF .deps/xte.Tpo -c -o xte.o xte.c
mv -f .deps/xte.Tpo .deps/xte.Po
gcc -DPACKAGE_NAME=\"xautomation\" -DPACKAGE_TARNAME=\"xautomation\" -DPACKAGE_VERSION=\"1.03\" -DPACKAGE_STRING=\"xautomation\ 1.03\" -DPACKAGE_BUGREPORT=\"\" -DPACKAGE=\"xautomation\" -DVERSION=\"1.03\" -DDEBUG_A_LOO=1 -DHAVE_LIBPNG=1 -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_STDLIB_H=1 -DHAVE_UNISTD_H=1 -DHAVE_WCHAR_H=1 -DHAVE_LOCALE_H=1 -DHAVE_STDLIB_H=1 -DHAVE_MALLOC=1 -DHAVE_BZERO=1 -DHAVE_WMEMSET=1 -DHAVE_MBSTOWCS=1 -I. -O2 -march=i486 -mtune=i686 -MT debug.o -MD -MP -MF .deps/debug.Tpo -c -o debug.o debug.c
mv -f .deps/debug.Tpo .deps/debug.Po
gcc -O2 -march=i486 -mtune=i686 -o xte xte.o debug.o -lXtst
/usr/lib/gcc/i486-slackware-linux/4.7.0/../../../../i486-slackware-linux/bin/ld: xte.o: ftp://ftp. reference to symbol 'XFree'
/usr/lib/gcc/i486-slackware-linux/4.7.0/../../../../i486-slackware-linux/bin/ld: note: 'XFree' is defined in DSO /usr/lib/libX11.so.6 so try adding it to the linker command line
/usr/lib/libX11.so.6: could not read symbols: Invalid operation
collect2: error: ld returned 1 exit status
make: *** [xte] Errore 1
fakeroot -- sh xautomation.SlackBuild Failed
*********************************************************
Qualche idea??Premetto che uso Slackel con kde 4.8.2!!Grazie anticipato e ciao!! :D
Last edited by Inserviente on 5. May 2012, 17:03, edited 1 time in total.

djemos
Salix Warrior
Posts: 1073
Joined: 29. Dec 2009, 13:45
Location: Greece

[Solved] Re: Problema pacchetto xautomation

Post by djemos » 1. May 2012, 18:46


User avatar
Inserviente
Posts: 76
Joined: 24. Sep 2011, 17:50
Location: Da qualche parte in Emilia Romagna(Italy)

Re: Problema pacchetto xautomation

Post by Inserviente » 2. May 2012, 20:26

PERFETTO!!!!!!Grazie Djemos,grazie tante,il mio mouse e la mia Slackel ringraziano!!!
σας ευχαριστώ! σας ευχαριστώ! σας ευχαριστώ! σας ευχαριστώ! σας ευχαριστώ! :D

Post Reply