aria maestosa e slackware/salix [RISOLTO]

Italian forum
Post Reply
tetragono
Posts: 6
Joined: 20. Sep 2010, 09:58

aria maestosa e slackware/salix [RISOLTO]

Post by tetragono » 18. Aug 2015, 21:50

Buongiorno.
Sto tentando di installare aria maestosa (il sequencer) su una distribuzione salix notevolmente "slackwarizzata" installando i pacchetti mancanti.
La compilazione si ferma con l'errore "cannot find wx_gtk2u_webview-3.0".
Ora ho installato wxgtk 3, wxgtk2, wxpython 2.8 e webkitgtk e webkitgtk3. Sapreste dirmi cosa è che manca?

Grazie

Buona serata
Last edited by tetragono on 21. Aug 2015, 08:37, edited 1 time in total.

User avatar
laprjns
Salix Warrior
Posts: 1028
Joined: 28. Aug 2009, 01:30
Location: Connecticut USA

Re: aria maestosa e slackware/salix

Post by laprjns » 21. Aug 2015, 00:29

Credo che tutto ciò che serve è wxGTK3 . Fai questo:

Code: Select all

$ sudo slapt-src --update 
$ sudo slapt-src --install wxGTK3

tetragono
Posts: 6
Joined: 20. Sep 2010, 09:58

Re: aria maestosa e slackware/salix [RISOLTO]

Post by tetragono » 21. Aug 2015, 08:36

Ciao.
Grazie della risposta. In effetti il pacchetto wxGTK3 installato penso non sia stato compilato avendo nel sistema le librerie webkitgtk e webkitgtk3.
Come suggeritomi dall'utente knudfl nei forum slackware di linuxquestions.org, ho disinstallato wxgtk2 (non so se è necessario questo, però), wxgtk3 e ho reinstallato wxgtk3 usando Sourcery (quindi ricompilandolo da zero, con le librerie webkitgtk e webkitgtk3 presenti, questa volta). Dopo di che ho reinstallato le wxPython 2.8, come suggerito nella pagina dello slackbuild delle wxgtk3, e la compilazione è andata a buon fine.
Adesso non riesco ad eseguire scons install, perché mi dà un errore di "file già presenti" al momento dell'installazione. Ma posso usare Aria Maestosa facendolo partire dalla directory dove è stato compilato. A me basta così, per ora.

Grazie del suggerimento.

Buona giornata.

Sim

User avatar
laprjns
Salix Warrior
Posts: 1028
Joined: 28. Aug 2009, 01:30
Location: Connecticut USA

Re: aria maestosa e slackware/salix [RISOLTO]

Post by laprjns » 21. Aug 2015, 11:55

I don't speak or write Italian so I used Google Translate in my first reply. I saw your post regarding this problem on the LinuxQuestions and see that you can read and write in English. I would suggest that in the future you post in the English section of this forum where more people would be able to respond.
Anyway in trying to find a solution to your problem, I tried to build ariamaestose and after installing wxGTK3 it successfully built but then ran into the same installation problem. I'm not sure where to go on this, so hopefully running out of the build directory work for you until you find a solution to the installation issue.

BTW, I built ariamaestore on a clean VM installation of Salix (full install) and the only dependency I had to install was wxGTK3. webkitgtk was already installed as part of the Salix full installation process.

User avatar
laprjns
Salix Warrior
Posts: 1028
Joined: 28. Aug 2009, 01:30
Location: Connecticut USA

Re: aria maestosa e slackware/salix [RISOLTO]

Post by laprjns » 21. Aug 2015, 17:40

Here are working packages for Aria Maestosa. Just down load the appropriate txz file for your machine and install it using spkg

Code: Select all

$ sudo spkg -i ariamaestosa-1.4.11-x86_64-rl1.txz
The only additional dependency that you will need to install is wxGTK3

Code: Select all

# sudo spi -i wxGTK3
''' 32 bit Package:'''
http://people.salixos.org/laprjns/ariam ... 86-rl1.md5
http://people.salixos.org/laprjns/ariam ... 86-rl1.txz
http://people.salixos.org/laprjns/ariam ... 86-rl1.dep

''' 64 bit Package:'''
http://people.salixos.org/laprjns/ariam ... 64-rl1.md5
http://people.salixos.org/laprjns/ariam ... 64-rl1.txz
http://people.salixos.org/laprjns/ariam ... 64-rl1.dep

tetragono
Posts: 6
Joined: 20. Sep 2010, 09:58

Re: aria maestosa e slackware/salix [RISOLTO]

Post by tetragono » 22. Aug 2015, 07:52

Hi.
Thanks for you suggestions. I think I did the same, i.e. I installed wxGTK3 and tried to compile Aria Maestosa, but I got that error.
Mine, is not a clean install Salix, so I probably made a mess somewhere, because beside some Slackware 14.1 official packages I installed a lot of packages from studioware and some packages compiled with Sourcery; or, maybe, I installed the wrong wxGTK3 before.
I will try the packages you posted soon.
In the meantime, thanks for your kindness.

Have nice days.

Sim

Post Reply