Impossibile scaricare apcchetti e aggiornamenti

Italian forum
Post Reply
leatherface
Posts: 10
Joined: 2. Feb 2016, 11:13

Impossibile scaricare apcchetti e aggiornamenti

Post by leatherface » 31. May 2016, 12:05

Ciao a tutti, da qualche settimana non riesco più ad installare aggiornamenti a pacchetti ogni volta che ci provo (sia da terminale che da sourcery o gslapt
mi viene semre questo messaggio di errore: 'Failed to download libjpeg: HTTP response code said error'.

Sapete dirmi come posso fare per risolvere?
Grazie.

User avatar
laplume
Donor
Posts: 332
Joined: 4. Sep 2010, 07:40
Location: (VI) Italy

Re: Impossibile scaricare apcchetti e aggiornamenti

Post by laplume » 1. Jun 2016, 16:45

Ciao,
Potresti provare a cambiare i server di riferimento.
Qui trovi la lista https://docs.salixos.org/wiki/Repository_mirrors
Da Gslapt vai in Modifica-Preferenze-Tab Origini
ed aggiungi le fonti che ti servono (occhio alle priorità: quelli che puntano a Slackware sono sempre Official; Quelli di Salix sono Preferred).
Io ho selezionato quelli di
http://salix.mirror.garr.it/mirrors/salix/
e vedo che funzionano.

Su sourcery onestamente non ricordo anche perché generalmente vado sul sito di Slacbkuilds.org e mi creo i pacchetti dagli script che sono lì.
Antonio

leatherface
Posts: 10
Joined: 2. Feb 2016, 11:13

Re: Impossibile scaricare apcchetti e aggiornamenti

Post by leatherface » 7. Jun 2016, 14:44

Ciao,
innanzitutto scusa la mia solita tempestività nel rispondere.

Prima che leggessi il tuo messaggio ho risolto in una maniera un po' strana: da terminale ho lanciato
slapt-get -autoclean
e, dopo,
slapt-get -clean

Dopo questo la libreria che mi dava problemi non era più libjpg ma libpng, ad ogni modo dovevo andare via a spensi il computer, al suo riavvio non avevo più questi problemi, ora aggiorno il sistema tranquillamente e sono pure riuscito ad installare okular (prima oltre a non aggiornare potevo anche scordarmi di installare pacchetti).

User avatar
laplume
Donor
Posts: 332
Joined: 4. Sep 2010, 07:40
Location: (VI) Italy

Re: Impossibile scaricare apcchetti e aggiornamenti

Post by laplume » 8. Jun 2016, 19:34

Ciao,
Bene, problema risolto anche se non si è capito come...
Forse avevi attivi più repo oltre a quelli ufficiali per cui Gslapt si inasina con le dipendenze. A me succede qualche volta quando attivi i repo di slacky. eu e scarico dei pacchetti che si tirano dietro altre dipendenze che sostituiscono pacchetti ufficiali. Cmq se poi risetto le fonti ufficiali mi chiede l'aggiornamento e tutto ritorna a posto.

Alla prossima,
Antonio

leatherface
Posts: 10
Joined: 2. Feb 2016, 11:13

Re: Impossibile scaricare apcchetti e aggiornamenti

Post by leatherface » 9. Jun 2016, 09:26

Sai che forse ha itrovato l'arcano?
In effetti tendo a smanettare (anche perchè penso che nel bene o nel male sia il modo più efficace perimparare ad usare un computer) però considerndo lemie attuali competenze nell'universo GNU/Linux errori come quello che hai ipotizzato gira evolta gli faccio.
Cmq l'importante è non arrendersi a trovare una soluzione. :D

Ciao,
Cristiano

User avatar
laplume
Donor
Posts: 332
Joined: 4. Sep 2010, 07:40
Location: (VI) Italy

Re: Impossibile scaricare apcchetti e aggiornamenti

Post by laplume » 9. Jun 2016, 17:41

Ciao,
Capita smanettando sul pc, e comunque effettivamente è il modo più diretto per imparare. Cmq mai paura, le community funzionano proprio per questo. :D

Ciao
Antonio

Post Reply