SSD v-nand e grub2

Italian forum
Post Reply
User avatar
franzy
Posts: 23
Joined: 2. Oct 2009, 10:33
Location: Salice Terme - IT
Contact:

SSD v-nand e grub2

Post by franzy » 25. Jul 2016, 18:51

ciao@tutti!..

ho un nuovo NUC6i5SYK + SSD v-nand 950 Pro M.2 su cui ho installato Slackware 14.2.
Tabella GPT con varie partizioni, di cui una da 1MB per bios-grub (lilo non supportato).
Riavviato tramite chiavetta USBSLACK, configurazione e installazione di grub2 senza problemi (dice l'output). Riavvio senza chiavetta, ma appare la shell di grub che dice disco non trovato. In questi casi il motivo principale è che grub non trova la sua dir /boot/grub. Lancio 'set' da grub rescue e mi esce 'prefix=(hd0,1)/boot/grub' e 'root=hd0'.
Ovvio che non va. Questi "dischi" sono rilevati come 'nvme0n1' e le partizioni 'nvme0n1p1, nvme0n1p2, ...'. Potrei resettare le due variabili per mettere tutto a posto, ma cosa ci metto al posto di 'hd0' (o sda0, lv0, md0, ...), cioè gli SSD v-nand con quale sigla sono gestiti da grub2?.. il manuale non lo cita. Per completezza, grub.cfg va bene così com'è, editato automaticamente. Workarounds?..
Image

User avatar
franzy
Posts: 23
Joined: 2. Oct 2009, 10:33
Location: Salice Terme - IT
Contact:

Re: SSD v-nand e grub2

Post by franzy » 28. Jul 2016, 16:45

come non detto... posterò altrove e... addio!
Image

Marco
Posts: 117
Joined: 10. Apr 2012, 17:43

Re: SSD v-nand e grub2

Post by Marco » 10. Aug 2016, 07:04

Azz.... in meno di una giornata già voleva la soluzione...... mmmmm un pò di presunzione?
Beh tante belle cose.
Se un uomo ha fame non regalargli un pesce, ma insegnagli a pescare.

Post Reply