WARNING: upgrade glibc-solibs with "upgradepkg" NOW

Post Reply
DidierSpaier
Posts: 303
Joined: 20. Jun 2016, 20:15

WARNING: upgrade glibc-solibs with "upgradepkg" NOW

Post by DidierSpaier » 1. Jul 2017, 06:17

The packages glibc-* have been upgraded

For some reason spkg (used as backend for spi and slapt-get in Slint) fails to run the post-installation script, that makes the system unusable, cf. this post.

To avoid that you need to do what follows before running gslapt or spi or slapt-get:
  1. Download the new most important glibc-* packages for your architecture (32-bit or 64-bit)
  2. Install them with upgradepkg
Instructions for Slint64-14.2 (64-bit), if "uname -m" reports "x86_64":
Type in a terminal

Code: Select all

wget http://ftp.slackware.com/pub/slackware/slackware64-14.2/patches/packages/glibc-2.23-x86_64-2_slack14.2.txz
wget http://ftp.slackware.com/pub/slackware/slackware64-14.2/patches/packages/glibc-solibs-2.23-x86_64-2_slack14.2.txz
su # to become root
upgradepkg glibc-2.23-x86_64-2_slack14.2.txz
upgradepkg glibc-solibs-2.23-x86_64-2_slack14.2.txz
Instructions for Slint-14.2 (32-bit), if "uname -m" reports "i686":
Type in a terminal

Code: Select all

wget http://ftp.slackware.com/pub/slackware/slackware-14.2/patches/packages/glibc-i18n-2.23-i586-2_slack14.2.txz
wget http://ftp.slackware.com/pub/slackware/slackware-14.2/patches/packages/glibc-solibs-2.23-i586-2_slack14.2.txz
su # to become root
upgradepkg glibc-2.23-i586-2_slack14.2.txz
upgradepkg glibc-solibs-2.23-i586-2_slack14.2.txz

djemos
Salix Warrior
Posts: 1056
Joined: 29. Dec 2009, 13:45
Location: Greece

Re: WARNING: upgrade glibc-solibs with "upgradepkg" NOW

Post by djemos » 1. Jul 2017, 08:30

I have same problems in slackel upgrading the glbc-* packages. Same problem also happens when upgrading samba package in current. I wrote this procedure for users to safely update their system.
This is very serious bug of spkg to have an unbootable system.
upgradepkg first does a pre-installation and then remove the old glibc package. I do not know what spkg does.

Edit: I rebuild slapt-get without the patch of spkg to use native installpkg/upgradedpkg/ from slackware. Since upgradepkg does a pre-installation.
I had a slackel-kde system (slackware current) in vmware and i upgraded there the slapt-get package and did a sudo slapt-get -i glibc and everything went fine.

User avatar
mimosa
Salix Warrior
Posts: 3066
Joined: 25. May 2010, 17:02
Contact:

Re: WARNING: upgrade glibc-solibs with "upgradepkg" NOW

Post by mimosa » 2. Jul 2017, 09:24

Is this something that should concern Salix users at all?

DidierSpaier
Posts: 303
Joined: 20. Jun 2016, 20:15

Re: WARNING: upgrade glibc-solibs with "upgradepkg" NOW

Post by DidierSpaier » 2. Jul 2017, 09:31

mimosa wrote:Is this something that should concern Salix users at all?
Maybe not currently with a stock Salix installation, but as Salix ships spkg and uses it in as back-end for slapt-get this bug *could* hurt Salix, I think.

I will let gapan (who is investigating) confirm or infirm.

User avatar
gapan
Salix Wizard
Posts: 5454
Joined: 6. Jun 2009, 17:40

Re: WARNING: upgrade glibc-solibs with "upgradepkg" NOW

Post by gapan » 4. Jul 2017, 23:03

This problem comes up only with glibc-solibs, which is not installed by default in Salix (and which is kind of a useless package in the first place with most installations -- that includes all Salix installations and all Slackware full installations). So it is not a problem for Salix. It also comes up only once. Upgrade it once, the problem comes up, run ldconfig right after, and it's fixed. No matter how many times you downgrade/upgrade glibc-solibs again, the problem never comes up again. So, it's rather hard to debug. I've found out what goes wrong, but I'm not sure yet why...
Image
Image

Post Reply