Akonadi not starting

Post Reply
User avatar
Posts: 539
Joined: 5. Jun 2011, 04:27

Akonadi not starting

Post by Atip » 11. Aug 2017, 08:05

I cannot get akonadi running and therefore cannot access programs which depend on it.

Code: Select all

akonadictl start 
ends with

Code: Select all

31: akonadiserver() [0x809ca92]
ProcessControl: Application 'akonadiserver' returned with exit code 255 (Unknown error)
"akonadiserver" crashed too often and will not be restarted!
How to correct?

User avatar
Salix Warrior
Posts: 1049
Joined: 28. Aug 2009, 01:30
Location: Connecticut USA

Re: Akonadi not starting

Post by laprjns » 11. Aug 2017, 10:21

Seems to run without problems on my machine. Maybe some here can help:
https://www.google.com/search?q=%22akon ... e&ie=UTF-8
“Don’t you see that the whole aim of Newspeak is to narrow the range of thought?"

Posts: 331
Joined: 20. Jun 2016, 20:15

Re: Akonadi not starting

Post by DidierSpaier » 11. Aug 2017, 10:30

Hi Atip,

I just tried in a fresh Slint64-14.2 installation with all patches applied, and everything seems to work:

Kmail starts
Korganizer starts

akonadictl start works
akonadictl stop works

By the way, you do not have to start akonadi manually, it is automatically started when you start an application that needs it.

Did you make a modification to your system (like adding/removing packages, whatever)?

Is your system up to date?

I didn't see anything in the upgrades that would have an influence, but just in case do this as root:

Code: Select all

slapt-get -u
slapt-get -i --reinstall spkg
slapt-get --upgrade
dotnew-gtk &
And try again.

PS laprjns aka Rich was answering while I was writing, you can follow his link too.

User avatar
Posts: 539
Joined: 5. Jun 2011, 04:27

Re: Akonadi not starting

Post by Atip » 12. Aug 2017, 04:10


Suggestions of DidierSpaier did not work.

On the website recommended by Laprjns I found:

Code: Select all

rm -rf ~/.local/share/akonadi/
rm -rf ~/.config/akonadi/
rm -rf ~/.kde/share/config/akonadi*
that worked. akonadi starts and stops and apps which need it open.

I did not make any modifications to the system. I am using fluxbox and found the problem
when I tried to use kalarm which I wanted to use since I could not make my "saytime"
program produce sound. Solved that by enabling in services alsa and alsa-oss. :)

Post Reply