[Solved] Pavucontrol Settings Not Holding

Post Reply
User avatar
Atip
Posts: 539
Joined: 5. Jun 2011, 04:27

[Solved] Pavucontrol Settings Not Holding

Post by Atip » 17. Sep 2017, 02:37

After a reboot the setting in pavucontrol Output Devices
always returns back to 73 % which is not loud enough for
my somewhat impaired hearing. ;)

How can I make the setting to stay permanent at 100 %?

Turning up the speaker volume is not a solution.
Last edited by Atip on 19. Sep 2017, 02:17, edited 1 time in total.

DidierSpaier
Posts: 312
Joined: 20. Jun 2016, 20:15

Re: Pavucontrol Settings Not Holding

Post by DidierSpaier » 17. Sep 2017, 09:30

Atip wrote:How can I make the setting to stay permanent at 100 %?
It stays after a reboot as it was before here.

I made several tests and to make sure compared the files in ~/.config/pulse before and after a reboot. The files that change if I increase or decrease the output volume are:
~/.config/pulse/<bignumber>-device-volumes. tdb
~/.config/pulse/<bignumber>-stream-volumes. tdb

They are not modified after a reboot, so I don't know why the behavior differs in your installation.

Which desktop or window manager are you running? In most of them there is a widget with a picture of a speaker on the right side of the bottom panel. Clicking on it allows to set the output volume as in pavucontrol.

As an aside, if you have several input sources you can set their volumes independently in pavucontrol. As it happens I am testing Orca (a software that says what is displayed on the desktop and spells what you type), and I can hear both Orca reading the content of a window and Parole playing a CD, and set the corresponding input volumes independently.

User avatar
Atip
Posts: 539
Joined: 5. Jun 2011, 04:27

Re: Pavucontrol Settings Not Holding

Post by Atip » 18. Sep 2017, 08:41

My desktop is fluxbox.
lxpanel has no volume control applet.

I opened xfce4 Desktop put the pavucontrol applet to the panel.
Increased volume from 76% to 100%
Rebooted.
Volume control again back to 76%
Files in ~/.config/pulse unchanged.

Opened Kde Plasma Desktop. Panel has a volume control set to 76%
Increased it to 100%.
Rebooted.
Volume control again back to 76%
Files in ~/.config/pulse unchanged.

All man might be equal to some, however, for sure not all computers are equal. ;)

User avatar
mimosa
Salix Warrior
Posts: 3096
Joined: 25. May 2010, 17:02
Contact:

Re: Pavucontrol Settings Not Holding

Post by mimosa » 18. Sep 2017, 09:00

I see much the same behaviour as Atip, and I'm running a largely unmodified Xfce installation. There is no such widget I can see (though there is a pretty useless power management one, perhaps because I'm using a laptop).

I can access "Pulse audio volume control" under Multimedia, but the settings revert on reboot.

DidierSpaier
Posts: 312
Joined: 20. Jun 2016, 20:15

Re: Pavucontrol Settings Not Holding

Post by DidierSpaier » 18. Sep 2017, 09:13

I think that you have both made /etc/rc.d/rc.pulseaudio executable, as If I do that I observe the same behavior.

Just typing as root

Code: Select all

chmod 644 /etc/rc.d/rc.pulseaudio
should solve this issue after a reboot.

Unless you need it for a very specific usage is is recommended not to start pulseaudio system wide.

Also Atip, I do have a volume control applet on the panel of firefox out of the box, maybe you removed it?

Anyway you can add widgets to the panel: click right on an empty part of it to do that.

You can also move horizontally a panel applet with the mouse : make and hold a middle click on it, then move it left or right.

User avatar
mimosa
Salix Warrior
Posts: 3096
Joined: 25. May 2010, 17:02
Contact:

Re: Pavucontrol Settings Not Holding

Post by mimosa » 18. Sep 2017, 09:23

I think that you have both made /etc/rc.d/rc.pulseaudio executable
No -

Code: Select all

ls -l /etc/rc.d/rc.pulseaudio
-rw-r--r-- 1 root root 1171 Jun 22  2016 /etc/rc.d/rc.pulseaudio
I've added the widget - but again, I didn't as far as I know do anything to interfere with the standard setup. I can only imagine that it is due to something like too many other items or small screen size causing it to disappear.

Incidentally, is this correct? Maybe that's what I changed without meaning to:

Code: Select all

pulseaudio (The pulseaudio service) : [off]
I'm assuming the settings will now be persistent; I'll report back if not.

Has anyone else seen anything like this, that is, either no widget, or sound settings reverting on reboot, or both?

DidierSpaier
Posts: 312
Joined: 20. Jun 2016, 20:15

Re: Pavucontrol Settings Not Holding

Post by DidierSpaier » 18. Sep 2017, 09:52

Mimosa, speaking of Xfce that's right it doesn't include a volume control applet in the panel by default in Slint 14.2. I probably should add it, do you agree?

Incidentally, this made me discover I can just drag the pulse audio volume control menu entry from the Multimedia menu and drop it to the panel to add it there. I must admit that I am a complete newbie there as I almost never use Xcfe :oops:

About the pulseaudio service, yes, it should be off.
I have checked that then in Xfce as well the volume setting holds. Here, at least.

User avatar
mimosa
Salix Warrior
Posts: 3096
Joined: 25. May 2010, 17:02
Contact:

Re: Pavucontrol Settings Not Holding

Post by mimosa » 18. Sep 2017, 10:11

I don't use xfce either but I recently installed it on my "travelling" laptop.

I just noticed this is the slint subforum - so I should say, mine is a Salix 14.2 installation.

I think it would be good to add it if the behaviour is different, that is, if settings done from the menu are really not persistent. This will avoid confusion for users, at least if they are using the default WM. Otherwise I wouldn't bother because I don't think it is unreasonable to have to go to a menu to adjust the volume. Multimedia apps will have their own controls, so the only situation where it should be needed is if the top volume is not high enough, as for me and Atip. It should only need to be changed once, if it is persistent.

westms
Posts: 298
Joined: 17. Mar 2013, 18:51

Re: Pavucontrol Settings Not Holding

Post by westms » 18. Sep 2017, 19:30

Atip wrote:My desktop is fluxbox.
lxpanel has no volume control applet.

I opened xfce4 Desktop put the pavucontrol applet to the panel.
Increased volume from 76% to 100%
Rebooted.
Volume control again back to 76%
Files in ~/.config/pulse unchanged.

Opened Kde Plasma Desktop. Panel has a volume control set to 76%
Increased it to 100%.
Rebooted.
Volume control again back to 76%
Files in ~/.config/pulse unchanged.

All man might be equal to some, however, for sure not all computers are equal. ;)
After your description, you have added a Pavucontrol applet to the panel in the XFCE environment. This is impossible because there is none. Maybe you added a PulseAudio plugin that is possible. The PulseAudio plugin has an input field for the audio mixer, which is pre-set with pavucontrol. Do you mean this? After the addition of the PulseAudio plugin, I had to reboot, because only then did it work properly. After that, I could adjust all the volume, which will remain after the boot. The only important finding/knowledge I have gained is that a PulseAudio plugin must be visible. Either in a panel or on the desktop.

Comparable will apply to fluxbox and others.

User avatar
Atip
Posts: 539
Joined: 5. Jun 2011, 04:27

Re: [Solved] Pavucontrol Settings Not Holding

Post by Atip » 19. Sep 2017, 02:29

Followed instructions and on reboot pavucontrol settings held
showing now Output Devices 100% as I had set. :D

Put sound volume control applet back to lxpanel.

Yes westms, that should read PulseAudio not Pavucontrol. :oops:

Now the files in ~/.config/pulse did change.

Post Reply