Slint64-14.2.1rc2, last call for testing.

DidierSpaier
Posts: 286
Joined: 20. Jun 2016, 20:15

Re: Slint64-14.2.1rc2, last call for testing.

Post by DidierSpaier » 20. Nov 2017, 09:14

Hello,
Atip wrote:python using 100 % of CPU.

This time I caught it and htop says:
python /usr/bin/hp-systray -x
Yes I have seen this also. What I did was to just remove the applet from the tray.

In the released ISO it will be disabled by default, just writing this line at the end of /etc/xdg/autostart/hplip-systray.desktop:

Code: Select all

Hidden=true
You can do that easily. As root type:

Code: Select all

echo "Hidden=true" >> /etc/xdg/autostart/hplip-systray.desktop
Anyway it doesn't make sense to have this on the panel for users who don't have an HP device.

I will just have to document how add one for the users who want that :?
Further, there was no /dev/audio during past boots.
So my program "saytime" would not work.
I copied /dev/audio over from Slint-32 and saytime
is working and /dev/audio survives a reboot sofar.
I have never seen that. I'd be curious to know have caused this. Thanks for reporting.

User avatar
Atip
Posts: 539
Joined: 5. Jun 2011, 04:27

Re: Slint64-14.2.1rc2, last call for testing.

Post by Atip » 21. Nov 2017, 08:50

Contrary of what I said yesterday /dev/audio copied from Slint-32
does not survive a reboot or halt. I just tried it 4 times. /dev/audio*
is absent after a reboot or halt..

Further: I have set inittab to runlevel 3. After login I type "startx"
and up comes my default desktop fluxbox.

If I set inittab to runlevel 4 and reboot I get now an ugly looking login
window, not the previous nice blue Slint, I enter my PW login and up comes
blackbox. This new login window does not give any choice for any other desktop.
:mrgreen:
/etc/X11/xinit/@xinitrc poits to xinitrc.fluxbox.

DidierSpaier
Posts: 286
Joined: 20. Jun 2016, 20:15

Re: Slint64-14.2.1rc2, last call for testing.

Post by DidierSpaier » 21. Nov 2017, 13:16

Hello,
Atip wrote:Contrary of what I said yesterday /dev/audio copied from Slint-32
does not survive a reboot or halt. I just tried it 4 times. /dev/audio*
is absent after a reboot or halt..
I have posted about this issue on the orca-list mailing list and received this answer. As, yes, saytime is an oldie (last release is ten years old) it probably expects to land in a system configured for OSS. So, look at the comments in /etc/rc.d/rc.alsa-oss if you still want to use it or (maybe easier) try to find a modern replacement. I don't think that be a Slint specific issue. In any case check that /etc/rc.d/rc.pulseaudio be non executable as you don't need a speaking desktop.
Further: I have set inittab to runlevel 3. After login I type "startx"
and up comes my default desktop fluxbox.

If I set inittab to runlevel 4 and reboot I get now an ugly looking login
window, not the previous nice blue Slint, I enter my PW login and up comes
blackbox. This new login window does not give any choice for any other desktop.
:mrgreen:
/etc/X11/xinit/@xinitrc points to xinitrc.fluxbox.
I replaced lxdm by lightdm by default as display manager recently because it can speak.
1) You can get back lxdm, just commenting out the lines that start lightdm in /etc/rc.d/rc.4
2) The login window of lightdm does allow choosing the desktop session, there is an icon for than on the top right of the screen.
3) You can theme lightdm runnning as root lightdm-gtk-greeter-settings
4) Yes, in RC2 the selection of the desktop session in lightdm is wrong if you use xwmconfig. This has been fixed now. To get the fixes do this:
a) If not already done edit /etc/slapt-get/slapt-getrc replacing in the slint source slint-14.2 with slint-testing
b) run as root:

Code: Select all

slapt-get --add-keys
slapt-get -u
slapt-get --upgrade
dotnew or dotnew-gtk
After that lightdm should honor the settings that you will make using xwmconfig as regular user.
To set the desktop session in lightdm (but only in lightdm, that's its limitation), I have also added a small script called session-chooser. Run it as regular user.

The recent changes and their rationale are as usual in the ChangeLog, after 09 November 2017.

User avatar
Atip
Posts: 539
Joined: 5. Jun 2011, 04:27

Re: Slint64-14.2.1rc2, last call for testing.

Post by Atip » 22. Nov 2017, 04:13

Actually the distros should not care if I have "saytime' and would not know.
Enabling in servicesetup alsa and alsa-oss does now put /dev/audio. :)

That brings up a new point:
Applications>System>System Servives opens nothing after given root PW.
However,

Code: Select all

sudo /usr/sbin/gtkservicesetup
opens the System Service window and I could enable alsa.

Further:
It was the upgrade which put my runlevel to 3 and changed rc.4 to
that new login. However, nicely copied the old rc.4 to rc.4.orig. Now
I put this back to rc.4, et voila the nice blue Slint login window is back. :D
Thank you.

DidierSpaier
Posts: 286
Joined: 20. Jun 2016, 20:15

Re: Slint64-14.2.1rc2, last call for testing.

Post by DidierSpaier » 22. Nov 2017, 06:30

Atip wrote: That brings up a new point:
Applications>System>System Servives opens nothing after given root PW.
However,

Code: Select all

sudo /usr/sbin/gtkservicesetup
opens the System Service window and I could enable alsa.
Here,
Applications>System>System Services opens the GUI after having given root PW.

On the other hand, sudo is not enabled by default in Slint, so I can't use sudo to start gtkservicesetup, this is refused.

Maybe you enabled sudo for your user and that changed the behavior?

PS, and if you did, maybe that's now your password as regular user that is expected by the GUI instead of the root password? Please try.

User avatar
Atip
Posts: 539
Joined: 5. Jun 2011, 04:27

Re: Slint64-14.2.1rc2, last call for testing.

Post by Atip » 23. Nov 2017, 01:05

If I enter my user PW I get:
Could not run '/usr/sbin/gtkservicesetup'
Invalid username or password
and I can enter a new PW.
Enterring then root PW input window disappears and nothing happens..

DidierSpaier
Posts: 286
Joined: 20. Jun 2016, 20:15

Re: Slint64-14.2.1rc2, last call for testing.

Post by DidierSpaier » 23. Nov 2017, 05:57

Atip wrote:If I enter my user PW I get:
Could not run '/usr/sbin/gtkservicesetup'
Invalid username or password
and I can enter a new PW.
Enterring then root PW input window disappears and nothing happens..
As I can't reproduce this behavior, it should be the result of a configuration or set up you did. Which one? Please give the exact steps you took, so I can try to reproduce. Did you enable sudo, in this case how did you do it, and any other relevant information. Thanks.

Also, did you click on the input field of the pop-up window before typing the password?

User avatar
Atip
Posts: 539
Joined: 5. Jun 2011, 04:27

Re: Slint64-14.2.1rc2, last call for testing.

Post by Atip » 24. Nov 2017, 02:00

Things are becoming crazy.

I booted this morning and my user password is not accepted.
Opened console logged-in to root and no PW required. :?:
Trying to change my user PW failed.
chpasswd: cannot lock /etc/passwd, try again later
Added a new user: guest
This guest has automatic sudo privileges.
I disabled it.
Tried system services and the same happens:
Entering root PW window disappears and nothing happens.
This might give you a clue:

Code: Select all

root[/home/guest]# /usr/sbin/gtkusersetup

(process:4197): Gtk-WARNING **: Locale not supported by C library.
	Using the fallback 'C' locale.
GTK Accessibility Module initialized
Traceback (most recent call last):
  File "/usr/sbin/gtkusersetup", line 343, in <module>
    locale.setlocale(locale.LC_ALL, '')
  File "/usr/lib64/python2.7/locale.py", line 581, in setlocale
    return _setlocale(category, locale)
locale.Error: unsupported locale setting
or

Code: Select all

root[/home/guest]# /usr/sbin/gtkservicesetup

(process:4319): Gtk-WARNING **: Locale not supported by C library.
	Using the fallback 'C' locale.
GTK Accessibility Module initialized
Traceback (most recent call last):
  File "/usr/sbin/gtkservicesetup", line 12, in <module>
    locale.setlocale(locale.LC_ALL, '')
  File "/usr/lib64/python2.7/locale.py", line 581, in setlocale
    return _setlocale(category, locale)
locale.Error: unsupported locale setting
Copied /etc/passwd and /etc/shadow over from Slint-32 and I can login again
with my PW. :)

DidierSpaier
Posts: 286
Joined: 20. Jun 2016, 20:15

Re: Slint64-14.2.1rc2, last call for testing.

Post by DidierSpaier » 24. Nov 2017, 08:00

Please answer this already asked question:
Did you enable sudo, in this case how did you do it, and any other relevant information.
Furthermore, you wrote:
Added a new user: guest
This guest has automatic sudo privileges
How did you do that? Which command did you use? This shouldn't happen in Slint.

To investigate on this:
Gtk-WARNING **: Locale not supported by C library.
Please tell us what is the output of:

Code: Select all

echo $LANG

User avatar
Atip
Posts: 539
Joined: 5. Jun 2011, 04:27

Re: Slint64-14.2.1rc2, last call for testing.

Post by Atip » 25. Nov 2017, 02:17

DidierSpaier wrote:Please answer this already asked question:
Did you enable sudo, in this case how did you do it, and any other relevant information.
Yes I enabled sudo in /etc/sudoers for me as user.

Furthermore, you wrote:
Added a new user: guest
This guest has automatic sudo privileges
How did you do that? Which command did you use? This shouldn't happen in Slint.
As root in console

Code: Select all

adduser guest
I did this when apparenty something was wrong with password.
Like my PW was not found and login as root w/o PW.
Now that password is fixed with copying /etc/passwd over from Slint-32
I cannot repeat it.
However, I always get the following error message when doing adduser:
nscd: relocation error: nscd: symbol __res_maybe_init, version GLIBC_PRIVATE not
defined in file libc.so.6 with link time reference
To investigate on this:
Gtk-WARNING **: Locale not supported by C library.
Please tell us what is the output of:

Code: Select all

echo $LANG

Code: Select all

$ echo $LANG
C
locale -a shows that there is C.

Post Reply