Slackel current rolling release (32 και 64 bit)

djemos
Salix Warrior
Posts: 1071
Joined: 29. Dec 2009, 13:45
Location: Greece

Re: Slackel current rolling release (32 και 64 bit)

Post by djemos » 9. Sep 2012, 18:14

you are right.

User avatar
mimosa
Salix Warrior
Posts: 3096
Joined: 25. May 2010, 17:02
Contact:

Re: Slackel current rolling release (32 και 64 bit)

Post by mimosa » 9. Sep 2012, 21:49

Thanks djemos :)

User avatar
mimosa
Salix Warrior
Posts: 3096
Joined: 25. May 2010, 17:02
Contact:

Re: Slackel current rolling release (32 και 64 bit)

Post by mimosa » 12. Sep 2012, 17:20

salix-codecs-installer appears to be broken in Slackel. Possibly in Salix current too?

The trouble I'm getting is at line 716. Also, it appears to depend on the urlgrabber module.

I have since installed all sorts of Gnomish stuff (in a hurry to finish the installation for a friend), somewhat at random, but to no avail.

djemos
Salix Warrior
Posts: 1071
Joined: 29. Dec 2009, 13:45
Location: Greece

Re: Slackel current rolling release (32 και 64 bit)

Post by djemos » 12. Sep 2012, 19:42

salix-codecs-installer is not broken. It is missing urlgrabber
Do a

Code: Select all

slapt-get -i urlgrabber
pycurl will installed also as a dep

Then run salix-codecs-installer.

User avatar
mimosa
Salix Warrior
Posts: 3096
Joined: 25. May 2010, 17:02
Contact:

Re: Slackel current rolling release (32 και 64 bit)

Post by mimosa » 12. Sep 2012, 21:32

I'd done that (see the second line of my post) - not sure if it picked up pycurl on the way. I decided to do it manually, but

Code: Select all

/usr/share/salix-codecs-installer/pkglist
was not present (/usr/share/salix-codecs-installer/foo.glade was). So I downloaded the package from 13.37, which also didn't work, but had the list.

I'm not sure what went wrong there (probably something I did) but it did occur to me afterwards that Slackel is likely to be at its most unstable just now - and that's fair enough. I'm still delighted to be able to show it to my friend who asked me to install Linux for him. The new KDE is looking great :)

User avatar
gapan
Salix Wizard
Posts: 5528
Joined: 6. Jun 2009, 17:40

Re: Slackel current rolling release (32 και 64 bit)

Post by gapan » 12. Sep 2012, 22:12

The new salix-codecs-installer doesn't need or use a list. It gets its information from the repos. And you're probably also missing pysimpleconfig.
Image
Image

User avatar
mimosa
Salix Warrior
Posts: 3096
Joined: 25. May 2010, 17:02
Contact:

Re: Slackel current rolling release (32 και 64 bit)

Post by mimosa » 12. Sep 2012, 22:26

That's clever. How does it tell which packages are relevant, though? I must have a look at the code!

djemos
Salix Warrior
Posts: 1071
Joined: 29. Dec 2009, 13:45
Location: Greece

Re: Slackel current rolling release (32 και 64 bit)

Post by djemos » 13. Sep 2012, 03:18

mimosa wrote:I'd done that (see the second line of my post) - not sure if it picked up pycurl on the way. I decided to do it manually, but

Code: Select all

/usr/share/salix-codecs-installer/pkglist
was not present (/usr/share/salix-codecs-installer/foo.glade was). So I downloaded the package from 13.37, which also didn't work, but had the list.

I'm not sure what went wrong there (probably something I did) but it did occur to me afterwards that Slackel is likely to be at its most unstable just now - and that's fair enough. I'm still delighted to be able to show it to my friend who asked me to install Linux for him. The new KDE is looking great :)
Did you upgrade from a previous release? In that case did you edit slapt-getrc?
For 64 bit is: (for 32 bit change x86_64 to i486.

Code: Select all

SOURCE=http://salix.enialis.net/x86_64/current/:PREFERRED
SOURCE=http://www.slackel.gr/repo/x86_64/slackware-current/:OFFICIAL
SOURCE=http://www.slackel.gr/repo/x86_64/slackware-current/extra/:OFFICIAL
SOURCE=http://www.slackel.gr/repo/x86_64/current/:CUSTOM
If you did a clean installation then urlgrabber and pycurl are not installed because i forgot to put them on package lists.
So after a slapt-get -u && slapt-get -i urlgrabber there is no problem at all.

I have installed and have checked Slackel kde-4.8.5. I use it for everyday use with no problems.
Slackel is stable. More stable than previous release because slackware is more stable now going to a new stable release.

All packages are on the repos. To see them

Code: Select all

slapt-get -u
slapt-get --search salix-codecs-installer pycurl urlgrabber pysimpleconfig
Don't use packages from 13.37. pycurl is on slackware current tree.

Code: Select all

slapt-get --clean
slapt-get -u
slapt-get -i --reinstall salix-codecs-installer pycurl urlgrabber pysimpleconfig 

User avatar
mimosa
Salix Warrior
Posts: 3096
Joined: 25. May 2010, 17:02
Contact:

Re: Slackel current rolling release (32 και 64 bit)

Post by mimosa » 13. Sep 2012, 10:54

Thanks djemos. Maybe I downgraded to salix-codecs-installer 13.37 before I got urlgrabber. I'll do as you suggest and see what happens. This was a fresh install I'm doing for a friend.

User avatar
mimosa
Salix Warrior
Posts: 3096
Joined: 25. May 2010, 17:02
Contact:

Re: Slackel current rolling release (32 και 64 bit)

Post by mimosa » 13. Sep 2012, 12:07

It doesn't matter, because I've already installed the codecs by hand; but that didn't work. I'm afraid I probably won't be able to help with any tests (at least not for long) because the owner of the drive wants to collect it. The only difference was upgrading the 13.37 salix-codecs-installer (sim = yes, não = no):

Code: Select all

root[jakson]# slapt-get --search pycurl pysimpleconfig salix-codecs-installer urlgrabber
pycurl-7.19.0-i486-2 [inst=sim]: pycurl (Python interface to cURL library)
pysimpleconfig-0.2-i486-1dj [inst=sim]: pysimpleconfig (Simple configuration file management in python)
pysimpleconfig-0.2-i486-2gv [inst=não]: pysimpleconfig (Simple configuration file management in python)
salix-codecs-installer-1.0.0-noarch-1dj [inst=sim]: salix-codecs-installer (install restricted multimedia codecs)
salix-codecs-installer-1.1.0-noarch-1gv [inst=não]: salix-codecs-installer (install restricted multimedia codecs)
urlgrabber-3.9.1-i486-1dj [inst=sim]: urlgrabber (A high-level cross-protocol url-grabber for python)
urlgrabber-3.9.1-i486-2gv [inst=não]: urlgrabber (A high-level cross-protocol url-grabber for python)
The messages are the same or similar. (Apologies for Portuguese) The final one means "floating point error":

Code: Select all

root[jakson]# salix-codecs-installer
No protocol specified
/usr/lib/python2.7/site-packages/gtk-2.0/gtk/__init__.py:57: GtkWarning: could not open display
  warnings.warn(str(e), _gtk.Warning)
/usr/sbin/salix-codecs-installer:649: Warning: invalid (NULL) pointer instance
  builder.add_from_file('/usr/share/salix-codecs-installer/salix-codecs-installer.glade')
/usr/sbin/salix-codecs-installer:649: Warning: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
  builder.add_from_file('/usr/share/salix-codecs-installer/salix-codecs-installer.glade')
/usr/sbin/salix-codecs-installer:649: GtkWarning: IA__gtk_settings_get_for_screen: assertion `GDK_IS_SCREEN (screen)' failed
  builder.add_from_file('/usr/share/salix-codecs-installer/salix-codecs-installer.glade')
/usr/sbin/salix-codecs-installer:649: Warning: g_object_get: assertion `G_IS_OBJECT (object)' failed
  builder.add_from_file('/usr/share/salix-codecs-installer/salix-codecs-installer.glade')
/usr/sbin/salix-codecs-installer:649: Warning: value "TRUE" of type `gboolean' is invalid or out of range for property `visible' of type `gboolean'
  builder.add_from_file('/usr/share/salix-codecs-installer/salix-codecs-installer.glade')
/usr/sbin/salix-codecs-installer:689: GtkWarning: IA__gtk_settings_get_for_screen: assertion `GDK_IS_SCREEN (screen)' failed
  self.treeviewcolumn_checkbox.set_title(_('Install'))
/usr/sbin/salix-codecs-installer:689: Warning: g_object_get: assertion `G_IS_OBJECT (object)' failed
  self.treeviewcolumn_checkbox.set_title(_('Install'))
/usr/sbin/salix-codecs-installer:691: GtkWarning: IA__gtk_settings_get_for_screen: assertion `GDK_IS_SCREEN (screen)' failed
  self.treeviewcolumn_pkgname.set_title(_('Name'))
/usr/sbin/salix-codecs-installer:691: Warning: g_object_get: assertion `G_IS_OBJECT (object)' failed
  self.treeviewcolumn_pkgname.set_title(_('Name'))
/usr/sbin/salix-codecs-installer:693: GtkWarning: IA__gtk_settings_get_for_screen: assertion `GDK_IS_SCREEN (screen)' failed
  self.treeviewcolumn_pkgver.set_title(_('Version'))
/usr/sbin/salix-codecs-installer:693: Warning: g_object_get: assertion `G_IS_OBJECT (object)' failed
  self.treeviewcolumn_pkgver.set_title(_('Version'))
/usr/sbin/salix-codecs-installer:695: GtkWarning: IA__gtk_settings_get_for_screen: assertion `GDK_IS_SCREEN (screen)' failed
  self.treeviewcolumn_pkgdesc.set_title(_('Description'))
/usr/sbin/salix-codecs-installer:695: Warning: g_object_get: assertion `G_IS_OBJECT (object)' failed
  self.treeviewcolumn_pkgdesc.set_title(_('Description'))
/usr/sbin/salix-codecs-installer:716: GtkWarning: Screen for GtkWindow not set; you must always set
a screen for a GtkWindow before using the window
  app.infowindow.show()
/usr/sbin/salix-codecs-installer:716: GtkWarning: IA__gdk_pango_context_get_for_screen: assertion `GDK_IS_SCREEN (screen)' failed
  app.infowindow.show()
/usr/sbin/salix-codecs-installer:716: PangoWarning: pango_context_set_font_description: assertion `context != NULL' failed
  app.infowindow.show()
/usr/sbin/salix-codecs-installer:716: PangoWarning: pango_context_set_base_dir: assertion `context != NULL' failed
  app.infowindow.show()
/usr/sbin/salix-codecs-installer:716: PangoWarning: pango_context_set_language: assertion `context != NULL' failed
  app.infowindow.show()
/usr/sbin/salix-codecs-installer:716: PangoWarning: pango_layout_new: assertion `context != NULL' failed
  app.infowindow.show()
/usr/sbin/salix-codecs-installer:716: PangoWarning: pango_layout_set_text: assertion `layout != NULL' failed
  app.infowindow.show()
/usr/sbin/salix-codecs-installer:716: PangoWarning: pango_layout_set_attributes: assertion `layout != NULL' failed
  app.infowindow.show()
/usr/sbin/salix-codecs-installer:716: PangoWarning: pango_layout_set_alignment: assertion `layout != NULL' failed
  app.infowindow.show()
/usr/sbin/salix-codecs-installer:716: PangoWarning: pango_layout_set_ellipsize: assertion `PANGO_IS_LAYOUT (layout)' failed
  app.infowindow.show()
/usr/sbin/salix-codecs-installer:716: PangoWarning: pango_layout_set_single_paragraph_mode: assertion `PANGO_IS_LAYOUT (layout)' failed
  app.infowindow.show()
/usr/sbin/salix-codecs-installer:716: PangoWarning: pango_layout_set_width: assertion `layout != NULL' failed
  app.infowindow.show()
/usr/sbin/salix-codecs-installer:716: PangoWarning: pango_layout_get_extents: assertion `layout != NULL' failed
  app.infowindow.show()
/usr/sbin/salix-codecs-installer:716: GtkWarning: IA__gtk_icon_theme_get_for_screen: assertion `GDK_IS_SCREEN (screen)' failed
  app.infowindow.show()
/usr/sbin/salix-codecs-installer:716: GtkWarning: IA__gtk_settings_get_for_screen: assertion `GDK_IS_SCREEN (screen)' failed
  app.infowindow.show()
/usr/sbin/salix-codecs-installer:716: GtkWarning: IA__gtk_icon_size_lookup_for_settings: assertion `GTK_IS_SETTINGS (settings)' failed
  app.infowindow.show()
/usr/sbin/salix-codecs-installer:716: GtkWarning: Invalid icon size 6

  app.infowindow.show()
/usr/sbin/salix-codecs-installer:716: GtkWarning: IA__gtk_icon_theme_load_icon: assertion `GTK_IS_ICON_THEME (icon_theme)' failed
  app.infowindow.show()
/usr/sbin/salix-codecs-installer:716: GtkWarning: Error loading theme icon 'dialog-question' for stock: 
  app.infowindow.show()
/usr/sbin/salix-codecs-installer:716: GtkWarning: gtkstyle.c:2358: invalid icon size '6'
  app.infowindow.show()
/usr/sbin/salix-codecs-installer:716: GtkWarning: IA__gtk_style_render_icon: assertion `pixbuf != NULL' failed
  app.infowindow.show()
/usr/sbin/salix-codecs-installer:716: Warning: g_object_ref: assertion `G_IS_OBJECT (object)' failed
  app.infowindow.show()
/usr/sbin/salix-codecs-installer:716: PangoWarning: pango_layout_set_wrap: assertion `PANGO_IS_LAYOUT (layout)' failed
  app.infowindow.show()
/usr/sbin/salix-codecs-installer:716: Warning: g_object_unref: assertion `G_IS_OBJECT (object)' failed
  app.infowindow.show()
/usr/sbin/salix-codecs-installer:716: GtkWarning: IA__gdk_screen_get_width: assertion `GDK_IS_SCREEN (screen)' failed
  app.infowindow.show()
/usr/sbin/salix-codecs-installer:716: PangoWarning: pango_layout_get_line_count: assertion `layout != NULL' failed
  app.infowindow.show()
Exceção de ponto flutuante

Post Reply