Difficulty building spectrwm

General talk about packaging procedures and packages.
Post Reply
User avatar
mimosa
Salix Warrior
Posts: 3103
Joined: 25. May 2010, 17:02
Contact:

Difficulty building spectrwm

Post by mimosa » 10. Sep 2012, 18:39

make fails with the following output:

Code: Select all

vanilla[linux]$ make
cc  -o spectrwm spectrwm.o linux.o -lX11 -lX11-xcb -lxcb -lxcb-icccm -lxcb-randr -lxcb-keysyms -lxcb-util -lxcb-xtest -lXft -lXcursor
/usr/lib/gcc/i486-slackware-linux/4.5.2/../../../../i486-slackware-linux/bin/ld: cannot find -lxcb-util
collect2: ld returned 1 exit status
make: *** [spectrwm] Error 1
Both libxcb and xcb-util are installed.

I should say I'm trying this in 13.37 before building for current. Searching didn't turn up anything that appeared to be helpful, though I did see a lot of hits for similar-looking errors.

Does anybody have any ideas?

User avatar
fredg
Posts: 232
Joined: 3. Oct 2009, 16:50
Location: Lyon, France
Contact:

Re: Difficulty building spectrwm

Post by fredg » 10. Sep 2012, 19:22

According to arch, here are the deps:

Code: Select all

    dmenu
    libxcursor
    libxft
    libxrandr
    profont
    xcb-util
    xcb-util-keysyms
    xcb-util-wm
    scrot (optional) - screenshots
    terminus-font (optional) - great font
    xlockmore (optional) - screenlocking
So, it seems that they are 3 xcb-util* pkgs, do you have them all ?

++

User avatar
mimosa
Salix Warrior
Posts: 3103
Joined: 25. May 2010, 17:02
Contact:

Re: Difficulty building spectrwm

Post by mimosa » 10. Sep 2012, 21:02

Right, so I suppose I'll have to build those as well.

Thanks fredg :)

EDIT

In fact all is probably well in current. At least one of those packages has been split from the old xcb-util. This thread at www.linuxquestions.org on a similar problem with awesome (IIRC, a tiling WM written in Lua) also includes a link to a tutorial:

http://www.linuxquestions.org/questions ... em-939825/

... so basically, getting either of these to work in 13.37 might be a problem, but not in current.

User avatar
Tim CowChip
Posts: 301
Joined: 27. May 2011, 03:35
Location: Cascade Locks, OR

Re: Difficulty building spectrwm

Post by Tim CowChip » 11. Sep 2012, 18:13

As I mentioned in this thread:

http://www.salixos.org/forum/viewtopic.php?f=22&t=3784
Tim CowChip wrote:This Linux Questions thread was referenced in the turtorial and talks about upgrading xcb-util0.3.6 to xcb-util-0.3.8 and installing xcb-icccm>=0.3.8 (which is now provided by xcb-util-wm). I tried using xcb-util-wm-0.3.9, but it didn't work xcb-util-wm-0.3.8 did work. I guess it would need to be bundled as well.
this was, of course, following the tutorial link instructions for building awesome and may or may not make any difference in building spectrwm-2.0.2.
ImageImage

User avatar
mimosa
Salix Warrior
Posts: 3103
Joined: 25. May 2010, 17:02
Contact:

Re: Difficulty building spectrwm

Post by mimosa » 11. Sep 2012, 20:39

Thanks Tim CowChip - I'll pursue those leads if I have further trouble.

Post Reply