anki

Here you can post links to your contributed packages.
Post Reply
User avatar
mimosa
Salix Warrior
Posts: 3103
Joined: 25. May 2010, 17:02
Contact:

anki

Post by mimosa » 22. Nov 2019, 20:36

Support for the version of Anki in the repositories is coming to an end and from January, it will no longer sync with the Anki cloud. The simplest way to continue to use it is to download this version bundled with static libraries:
https://apps.ankiweb.net/downloads/curr ... te.tar.bz2
Even so it has one or two dependencies, including Wayland.

Under these circumstances, creating a new package would require a fair bit of work which I don't feel is justified.

To use it, unpack it somewhere and put a wrapper script in your path. The executable needs to be called from within the top directory unpacked from the tarball. I put this in /usr/local/share, with the following script located in /usr/local/bin:

Code: Select all

#!/bin/bash
cd /usr/local/share/anki-2.1.15-linux-amd64-alternate/
/usr/local/share/anki-2.1.15-linux-amd64-alternate/bin/anki
Make it executable:

Code: Select all

sudo chmod +x /usr/local/bin/anki
Unistall the old anki before running it. The local copy of your decks should be left intact, but it is probably better to back it up first just in case:

Code: Select all

cp -r ~/Documents/Anki ~/Documents/Anki_backup

Post Reply