pdfshuffler - PACKAGE REQUIRED

General talk about packaging procedures and packages.
Post Reply
salix_user
Posts: 33
Joined: 23. Jan 2019, 13:15

pdfshuffler - PACKAGE REQUIRED

Post by salix_user » 24. Mar 2020, 20:54

JFYK

Install pdfshuffler from salix's repo

$ pdfshuffler
Error: Could not import pdfshuffler
Cause: No module named poppler
$ sudo slapt-get -i pypoppler

$ pdfshuffler
Error: Could not import pdfshuffler
Cause: No module named PyPDF2
$ sudo slapt-get -i pyPdf

$ pdfshuffler starts successfully and works Ok.

It makes sense to add these deps to 'PACKAGE REQUIRED:' in http://download.salixos.org/i486/extra-14.2/PACKAGES.TXT

User avatar
gapan
Salix Wizard
Posts: 5573
Joined: 6. Jun 2009, 17:40

Re: pdfshuffler - PACKAGE REQUIRED

Post by gapan » 25. Mar 2020, 14:49

Added. Thanks!
Image
Image

Post Reply