? about gjots2

General talk about packaging procedures and packages.
salix_user
Posts: 33
Joined: 23. Jan 2019, 13:15

? about gjots2

Post by salix_user » 25. Mar 2020, 08:20

I am trying to run gjots2 3.0.1 on salix14.2
gjots2(1) is a simple jotter application for your desktop - an outline processor.
You can use gjots2(1) to organise your jottings into a tree structure, adding thoughts and miscellany as you go. You can get it to spit out HTML, XML, postscript, pdf, man etc etc (see the online manual for an example of the HTML conversion).
You can use it to "mind-map" your compositions - write down all your thoughts and then start organising them into a tree. By manipulating the tree you can easily reorder your thoughts and structure them appropriately.
It requires python3.7 or higher.
I have installed python3 from Eric's repo

Image

But

Code: Select all

$ gjots2
gjots2 requires python3.7 or higher.
$
Probably, this is because

Code: Select all

[~]$ python -V
Python 2.7.17
[~]$
But AFAIK I can have several other versions of python

gjots2's developer suggested
$ python3 /usr/bin/gjots2
or
$ python3.7 /usr/bin/gjots2
But

Code: Select all

[~]$ python3.7 /usr/local/bin/gjots2
Traceback (most recent call last):
  File "/usr/local/bin/gjots2", line 83, in <module>
    import gi
ModuleNotFoundError: No module named 'gi'

[~]$ python3 /usr/local/bin/gjots2
Traceback (most recent call last):
  File "/usr/local/bin/gjots2", line 83, in <module>
    import gi
ModuleNotFoundError: No module named 'gi'
[~]$
gjots2's developer answered:
You need to install python3-gobject-base (fedora) or whatever it's
called on ubuntu. It lives at
https://wiki.gnome.org/Projects/PyGObject
But I already have

Image

Please, help.

User avatar
mimosa
Salix Warrior
Posts: 3123
Joined: 25. May 2010, 17:02
Contact:

Re: ? about gjots2

Post by mimosa » 25. Mar 2020, 10:30

You need py3gobject (just above in your screen capture).

salix_user
Posts: 33
Joined: 23. Jan 2019, 13:15

Re: ? about gjots2

Post by salix_user » 25. Mar 2020, 12:50

mimosa wrote:
25. Mar 2020, 10:30
You need py3gobject (just above in your screen capture).
I have installed it but the same problem stiil exists

User avatar
gapan
Salix Wizard
Posts: 5573
Joined: 6. Jun 2009, 17:40

Re: ? about gjots2

Post by gapan » 25. Mar 2020, 14:21

Zim, which is included in a default installation, is probably better.
Image
Image

User avatar
gapan
Salix Wizard
Posts: 5573
Joined: 6. Jun 2009, 17:40

Re: ? about gjots2

Post by gapan » 25. Mar 2020, 14:50

Oh, and BTW, your "upgrading" of the python3 package will certainly break everything in the repos that depends on python3.
Image
Image

salix_user
Posts: 33
Joined: 23. Jan 2019, 13:15

Re: ? about gjots2

Post by salix_user » 25. Mar 2020, 18:15

gapan wrote:
25. Mar 2020, 14:50
Zim, which is included in a default installation, is probably better.
I don't like zim. gjots's GUI is more convenient for me.
+
gjots2 supports the use of ccrypt, gpg and openssl to encrypt and decrypt files.
gapan wrote:
25. Mar 2020, 14:50
Oh, and BTW, your "upgrading" of the python3 package will certainly break everything in the repos that depends on python3.
1 How about backward compatibility?
2 If this alien's python3.7.3 work for the original 14.2, then why doesn't it work for salix ?

User avatar
gapan
Salix Wizard
Posts: 5573
Joined: 6. Jun 2009, 17:40

Re: ? about gjots2

Post by gapan » 25. Mar 2020, 18:27

Slackware 14.2 does not include any python3. We do include python 3.5. And we have several packages that depend on python 3.5. If you upgrade to 3.7, they will stop working. There is no backwards compatibility in python in that sense.
Image
Image

salix_user
Posts: 33
Joined: 23. Jan 2019, 13:15

Re: ? about gjots2

Post by salix_user » 25. Mar 2020, 18:54

gapan wrote:
25. Mar 2020, 18:27
Slackware 14.2 does not include any python3. We do include python 3.5. And we have several packages that depend on python 3.5. If you upgrade to 3.7, they will stop working. There is no backwards compatibility in python in that sense.
But Eric have created this python3.7.3 for 14.2

+ AFAIK A user can have a few versions of Python installed on the machine.
So, I can install and 3.5.
?

User avatar
gapan
Salix Wizard
Posts: 5573
Joined: 6. Jun 2009, 17:40

Re: ? about gjots2

Post by gapan » 25. Mar 2020, 19:50

salix_user wrote:
25. Mar 2020, 18:54
But Eric have created this python3.7.3 for 14.2
Yes, indeed. As I wrote, python 3.7 will work. Packages that depend on python 3.5, which you will have removed, will stop working.
salix_user wrote:
25. Mar 2020, 18:54
+ AFAIK A user can have a few versions of Python installed on the machine.
So, I can install and 3.5.
?
It depends. There is a /usr/bin/python3 symlink that will point to either python3.5 or python3.7. If something depends on python 3.5 and the symlink points to python3.7, and it is launched with /usr/bin/python3, then it won't work. The opposite won't work either. So, in any case, if you do anything like that, you're looking for trouble.

I'll point you to this wiki page now: https://docs.salixos.org/wiki/Can_I_use ... itories%3F
Image
Image

salix_user
Posts: 33
Joined: 23. Jan 2019, 13:15

Re: ? about gjots2

Post by salix_user » 25. Mar 2020, 21:04

gapan wrote:
25. Mar 2020, 18:27
We do include python 3.5. And we have several packages that depend on python 3.5. If you upgrade to 3.7, they will stop working.
How do I find out these packages ? You mean some fundamental pkgs ?

Post Reply