Installing LXDE on Salix 14

User avatar
laprjns
Salix Warrior
Posts: 1039
Joined: 28. Aug 2009, 01:30
Location: Connecticut USA

Re: Installing LXDE on Salix 14

Post by laprjns » 24. Mar 2013, 11:56

Salixified wrote: The only package missing is "lxde-common."
The wiki instructions for installing LXDE where developed for 13.37. Since there is not an official version of LXDE for Salix 14.0 the package list needed to install LXDE may be different and they may not all be in the 14.0 repo yet. So installing the LXDE packages that are already in the repo may not result in the complete LXDE environment.
Salixified wrote: Apparently even PCManFM was installed, so it must have been "in there" somewhere even though it doesn't show up in the list when Gslapt is opened.
What you most likely have installed is spacefm which is a fork of pcmanfm. See http://ignorantguru.github.com/spacefm/ ... on-history. I'm not sure how it got installed thought; its not a dependancy of any of the lxde packages in the repo.
Salixified wrote: Nice to see Xournal in Sourcery too - an unexpected treat.
Be aware that Sourcery and its command line equivalent slapt-src are tools to build and install packages from source. They both have limited dependency resolution capability so you can expect to run into dependency issues with some of the packages. if you run into any problems and can't resolve them yourself just post it here and someone will come alone and help.
“Don’t you see that the whole aim of Newspeak is to narrow the range of thought?"

User avatar
Salixified
Posts: 20
Joined: 23. Mar 2013, 22:58
Location: Florida, USA
Contact:

Re: Installing LXDE on Salix 14

Post by Salixified » 24. Mar 2013, 12:16

laprjns wrote:... So installing the LXDE packages that are already in the repo may not result in the complete LXDE environment.
It most definitely did not. :lol:
laprjns wrote: What you most likely have installed is spacefm which is a fork of pcmanfm. See http://ignorantguru.github.com/spacefm/ ... on-history. I'm not sure how it got installed though; its not a dependancy of any of the lxde packages in the repo.
Apparently neither was installed. But thanks for the link, I'm curious about this new stuff.
laprjns wrote: Be aware that Sourcery and its command line equivalent slapt-src are tools to build and install packages from source. They both have limited dependency resolution capability so you can expect to run into dependency issues with some of the packages. if you run into any problems and can't resolve them yourself just post it here and someone will come alone and help.
Y'all have been just great so far. I'll do a lot more reading first before asking questions here, but it's nice to have such great community support. Thanks so much!
Another totally Salixified customer!

User avatar
mimosa
Salix Warrior
Posts: 3103
Joined: 25. May 2010, 17:02
Contact:

Re: Installing LXDE on Salix 14

Post by mimosa » 24. Mar 2013, 14:17

The next thing I was going to do was actually look at the LXDE wiki instructions and maybe even get out of my armchair and test them. :oops:

In any case, if you're enjoying Xfce, you're clearly Salixified. In the not too distant future a variety of other flavours should be available for 14.0, many of them in Live CD versions :) Everything except KDE is pretty snappy even on quite basic hardware.

User avatar
Salixified
Posts: 20
Joined: 23. Mar 2013, 22:58
Location: Florida, USA
Contact:

Re: Installing LXDE on Salix 14

Post by Salixified » 24. Mar 2013, 16:28

I appreciate that Mimosa, but I'm the one who should out of the easy chair and working on this - if I really cared enough about it to bother, that is. As you say, I'm truly Salixified, so no bother. Got all the "partial" bits of LXDE and Openbox that were installed removed and cleansed from my computer, and quite content to wait for the LXDE version to come out before toying with LXDE.

Yours very cordially and gratefully,
A Salixified User
Another totally Salixified customer!

User avatar
Pai Mei
Donor
Posts: 13
Joined: 13. Jan 2012, 02:17
Location: Brazil

Re: Installing LXDE on Salix 14

Post by Pai Mei » 11. May 2013, 03:00

I'm sorry for reviving this thread, and becoming a bit impertinent, but I installed LXDE successfully in SALIX 14 64 bits XFCE, using the ponce.cc packages - the packages are for 32 and 64 bits versions of Slackware... Solved dependencies problems, and have PCManfm running without problems... If you want, I can write a walkthrough for this...
Sorry if I was a bit silly.
Image
Linux User #551004
Pentium Core2Duo E5700 4Gb Ram
Salix 14 XFCE 64 bits Multilib / Openbox / LXDE

User avatar
husnia
Posts: 3
Joined: 23. May 2013, 17:31

Re: Installing LXDE on Salix 14

Post by husnia » 26. May 2013, 18:11

hi everyone

I'm using salix 13.37 KDE on my laptop. but now I want to change the KDE with LXDE.

I've install the packages as written on wiki. then I logout to choose LXDE but it doesn't show up on session menu.

is there anything that I miss?

thanks
:)

User avatar
knome
Donor
Posts: 163
Joined: 20. Dec 2012, 19:36
Location: UK

Re: Installing LXDE on Salix 14

Post by knome » 26. May 2013, 21:33

husnia wrote:hi everyone

I'm using salix 13.37 KDE on my laptop. but now I want to change the KDE with LXDE.

I've install the packages as written on wiki. then I logout to choose LXDE but it doesn't show up on session menu.

is there anything that I miss?

thanks
:)
Assuming you're using the KDM session manager then the following may help...

http://www.salixos.org/forum/viewtopic.php?p=2876
Image

User avatar
husnia
Posts: 3
Joined: 23. May 2013, 17:31

Re: Installing LXDE on Salix 14

Post by husnia » 27. May 2013, 04:58

thanks knome. it work. :D

flexit
Posts: 1
Joined: 1. Jun 2013, 02:57

Re: Installing LXDE on Salix 14

Post by flexit » 1. Jun 2013, 03:13

I am running 13.37 LXDE edition and would like to upgrade to 14.0. I would like to keep LXDE and don't care if there are newer packages. So, is it safe to follow the documented upgrade procedure, skipping the XFCE upgrade part, of course. I wonder if anyone has attempted that?

User avatar
gapan
Salix Wizard
Posts: 5538
Joined: 6. Jun 2009, 17:40

Re: Installing LXDE on Salix 14

Post by gapan » 5. Jun 2013, 19:19

flexit wrote:I am running 13.37 LXDE edition and would like to upgrade to 14.0. I would like to keep LXDE and don't care if there are newer packages. So, is it safe to follow the documented upgrade procedure, skipping the XFCE upgrade part, of course. I wonder if anyone has attempted that?
No, LXDE is not yet available for 14.0.
Image
Image

Post Reply