Salix Xfce 14.2beta1

User avatar
gapan
Salix Wizard
Posts: 5523
Joined: 6. Jun 2009, 17:40

Re: Salix Xfce 14.2beta1

Post by gapan » 27. Jul 2016, 19:52

GeBruns wrote:gapan, I observed it in the LibreOffice Writer dialogs mentioned above. Menu 'Tools' > 'Customize' dialog, Menu 'Format' > 'Character' dialog and Menu 'Format' > 'Paragraph' dialog. That are just three examples.

As language I use "en_US.utf8".
I see nothing out of the ordinary here.
GeBruns wrote:Before installation I disabled UEFI and Secure Boot. After starting Salix64 beta1 installation from a USB drive I choose to use English language (US) for installation. The kernel began to boot but after three seconds a kernel panic occurred.

Are there any options I could try?
What happens if you have UEFI enabled? Make sure you keep SecureBoot disabled though.
Image
Image

User avatar
gapan
Salix Wizard
Posts: 5523
Joined: 6. Jun 2009, 17:40

Re: Salix Xfce 14.2beta1

Post by gapan » 27. Jul 2016, 21:01

Papasot wrote:I'm not sure about NetworkManager and Pulseaudio, actually I dislike them, and I don't want to use them. But I guess I'll find a way to get rid of them, and replace them with the corresponding tried-and-true applications used in 14.1.
You can definitely replace NetworkManager with wicd. Or even remove it and use netconfig/netsetup to configure an ethernet connection if you're only connecting with wire. Pulseaudio should not be that easy to get rid of though, there are a lot of packages that require it as a dependency. You could however disable it, use alsa as the default sound server and pulseaudio only when it's absolutely needed:
https://wiki.archlinux.org/index.php/Pu ... pe_to_ALSA
Papasot wrote:Just a question, I have the 32- and 64-bit versions of Salix 14.2 alpha1 installed - just for testing purposes right now. I assume regular updates will keep me up-to-date?
Yes, of course. There may be some changes to default configuration, but if you have a system that is OK for you, no need to replace it.
Image
Image

User avatar
gapan
Salix Wizard
Posts: 5523
Joined: 6. Jun 2009, 17:40

Re: Salix Xfce 14.2beta1

Post by gapan » 27. Jul 2016, 21:30

westms wrote:1. After I had installed Salix64 Xfce 14.2beta1 first time, I installed the multimedia codecs. It noticed that QT4 (qt-4.8.7-x86_64-4.txz) is on the list of selectable codecs and which is also installed. Is that intended?
The openal-soft package included a GUI configuration tool that uses qt4. I have rebuilt the package to not include it now, so qt should not be needed anymore.
westms wrote:2. There is a typo in a message text of operation "Aktualisiere lokalen Paket-Cache". In the message to action "Empfnage Paketdaten..." interchanged letters are contained. Correct is "Empfange Paketdaten...".

3. During the installation of the beta1 in German language, I noticed that some windows yet contain English texts. Then I checked Dutch, Swedish, Italian and French. Only for the Swedish language it seems, a full translation already exist (the non-German installations I always canceled after the disk partitioning). Probably the translation work is not finished yet. Should I at this time be more specific?
Contributions to translations are always welcome:
http://salixos.org/translate.html
westms wrote:1 In .xsession-errors there are two warning messages:
"(xfce4-session:1096): xfce4-session-WARNING **: xfsm_manager_load_session: Something wrong with /home/westms/.cache/sessions/xfce4-session-darkstar:0, Does it exist? Permissions issue?"

The message is the whole thing between the two double quotes. In fact, there is no directory xfce4-session-darkstar:0 . There is only a directory thumbs-darkstar:0
Do you have the "Save session" option checked when logging out of xfce? I get that too, but I never save the xfce session. As far as I can see, that's just a warning, not an error. So it shouldn't matter much.
westms wrote:2. Another message in .xsession-errors:
xscreensaver: 22:12:59: couldn't get password of "root"
Fehlgeschlagen: Modulinitialisierung fehlgeschlagen


The last line in English would be: "Failed: module initialization failed"
I don't get that here. There is no reason xscreensaver should need the root password. I don't know why you get that message.
westms wrote:3. Something is wrong, because I see the following three lines at the boot screen:

Code: Select all

darkstar login: swap               : ignored
/               : ignored
/mnt/floppy               : ignored
Only runlevels 3 and 4 are affected. Some seconds after reaching the runlevel, these three lines appear.
These are only informational. I can see those too. I don't think there is anything wrong. If you can find out what is producing them, maybe we could find a way to make them disappear.
westms wrote:is CUPS already operational? I tried to add a printer (http://localhost:631/admin), but failed.
Yes, it is. Make sure you have this line in your /etc/cups/cupsd.conf:

Code: Select all

SystemGroup sys root wheel
You might have replaced it without knowing while running dotnew.

Or, enable the root user password and use it...
Image
Image

User avatar
gapan
Salix Wizard
Posts: 5523
Joined: 6. Jun 2009, 17:40

Re: Salix Xfce 14.2beta1

Post by gapan » 27. Jul 2016, 21:32

mimosa wrote:Network Manager does not autoconnect to a wireless signal I am now using. I think it did autoconnect to ethernet, before. I installed wicd and it does autoconnect.
Can you try checking the "Allow all users to connect to this network" option in the wireless network options in NetworkManager? I don't remember the exact wording...
Image
Image

bin bash
Posts: 14
Joined: 26. Jul 2016, 18:22

Re: Salix Xfce 14.2beta1

Post by bin bash » 27. Jul 2016, 23:07

I downloaded and installed the 14.2 beta 1 version. It looks very nice, I like that it comes with Libre office.
However I was unable to connect to the internet. It recognized my wifi AirCard Network but would not connect or give me the options to enter my passphrase.

A wired ethernet connection is not an option for me. So I reinstalled Salix 14.1. This connects flawlessly, using fluxbox.
Edit: I just noticed, Salix 14.1 uses wicd network manager, that must be the difference.
Can I install wicd in 14.2 beta 1? I would really like to be able to use Salix 14.2.
Edit; I reinstalled 14.2 beta 1 and tried networking my computers together, if perhaps I could get online that way.
It has worked in the past but no success this time.

User avatar
Atip
Posts: 539
Joined: 5. Jun 2011, 04:27

Re: Salix Xfce 14.2beta1

Post by Atip » 28. Jul 2016, 08:04

If I continue to upgrade will I then eventually have the final version w/o having to reinstall?

User avatar
gapan
Salix Wizard
Posts: 5523
Joined: 6. Jun 2009, 17:40

Re: Salix Xfce 14.2beta1

Post by gapan » 28. Jul 2016, 08:59

Atip wrote:If I continue to upgrade will I then eventually have the final version w/o having to reinstall?
Mostly, yes.
Image
Image

User avatar
mimosa
Salix Warrior
Posts: 3094
Joined: 25. May 2010, 17:02
Contact:

Re: Salix Xfce 14.2beta1

Post by mimosa » 28. Jul 2016, 10:29

gapan wrote:
mimosa wrote:Network Manager does not autoconnect to a wireless signal
Can you try checking the "Allow all users to connect to this network" option in the wireless network options in NetworkManager?
That worked.

bin bash, please see my response to your query in the Salix Pub. In a nutshell, you can just install wicd, but probably, Network Manager will work too; in the unlikely event it is related to kernel support for your hardware, that can be solved as well.

GeBruns
Donor
Posts: 17
Joined: 9. Jan 2016, 22:26
Location: Northern Germany

Re: Salix Xfce 14.2beta1

Post by GeBruns » 28. Jul 2016, 14:29

gapan wrote:What happens if you have UEFI enabled? Make sure you keep SecureBoot disabled though.
If UEFI is enabled, I can install it without problems. But during first boot, I got a couple of errors running down the screen. I could read just one of them:

Code: Select all

...[drm:gen8_irq_handler [i915]] *ERROR* Fault errors on pipe A
Would it be possible to install a newer kernel between installation and first boot?

bin bash
Posts: 14
Joined: 26. Jul 2016, 18:22

Re: Salix Xfce 14.2beta1

Post by bin bash » 28. Jul 2016, 14:34

mimosa wrote:
gapan wrote:
mimosa wrote:Network Manager does not autoconnect to a wireless signal
Can you try checking the "Allow all users to connect to this network" option in the wireless network options in NetworkManager?
That worked.

bin bash, please see my response to your query in the Salix Pub. In a nutshell, you can just install wicd, but probably, Network Manager will work too; in the unlikely event it is related to kernel support for your hardware, that can be solved as well.
Thank you, for the informative reply.
I cannot find this option in the network manager
"Can you try checking the "Allow all users to connect to this network" option in the wireless network options in NetworkManager?"
Where is it hiding ????

Locked