Cut a new 14.2.1 ISO with working repositories

If you have any suggestions or ideas about improving Salix, here's the place to post them.
Post Reply
Nanook
Posts: 7
Joined: 18. Jan 2019, 05:32

Cut a new 14.2.1 ISO with working repositories

Post by Nanook » 22. Jan 2019, 05:52

I recently installed 14.2.1 and found immediately that slapt-get did not work owing to repositories that did not work. It would to me a very basic thing to make sure your most recent install ISO has good repos in it.

salix_user
Posts: 1
Joined: 23. Jan 2019, 13:15

Re: Cut a new 14.2.1 ISO with working repositories

Post by salix_user » 23. Jan 2019, 13:22

The default mirrors (in the iso_14.2.1) do not work anymore.
Just change ones to https://docs.salixos.org/wiki/Repository_mirrors
You can do this in GUI or edit your /etc/slapt-get/slapt-getrc and /etc/slapt-get/slapt-srcrc configuration files.

User avatar
mimosa
Salix Warrior
Posts: 3103
Joined: 25. May 2010, 17:02
Contact:

Re: Cut a new 14.2.1 ISO with working repositories

Post by mimosa » 23. Jan 2019, 14:09

I think the trouble with making a new release to correct this is it would have to include updates since the original release and at this stage in the release cycle that would be non-trivial. A quick search on the forum would probably have been enough to resolve the problem, and while I agree it's not good to face a hiccup like this at such an early stage, this is not a distro aimed at total beginners (though it generally works surprisingly well for that audience).

A convenient tool for changing repositories is reposetup.

As has also been said elsewhere, I recommend having a look at the Salix Startup Guide, linked to from the homepage.

Post Reply